Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

ISLE fails to install VS2013 WindowsService application completely


I have successfully converted a number of VS2010.VisualStudioInstaller Windows Service application solutions to VS2013.ISLE without any problems or issues.
Just now I have built a new VS2013 Windows Service application for which there is no prior VSI installer, and so I'm adding the ISLE project to install it.
I've configured the ISLE setup project, and it runs and creates/populates the application folders, and the installed application shows up in Add/RemovePrograms, but it does NOT show up in the WindowsServices dialog/list.
My conversions had created-in-VS2010 ServiceInstaller/ServiceProcessInstaller objects, and I've tried the VS2013.ISLE setup both with them and by using the ConfigureTheTargetSystem.Services, but neither has worked.

It seems like I'm missing something simple, but I can't put my finger on it.

Please advise!
0 Kudos
(2) Replies
Level 17

Have you checked this blog post?
0 Kudos
Level 3

Voila, nice and simple; thanks!
0 Kudos