Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Error:- 1603 Fatal error during installation

Using trial version of installshield 2019, converted .msi project created using IS developer 8.0 edition. On install progress while "Rolling Back Actions." gets the error message "Error:- 1603 Fatal error during installation". The setup.exe built using the old installer before conversion is working without this error


Would you please help to figure out the reason for this issue and a solution

0 Kudos
(7) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Upgrading to a version of Installshield that was released close to 20 years later than Developer 8 is always going to carry the risk of problems.
If your project is not too complex then I would suggest seriously considering creating your project again from scratch in the new Installshield version.
Whilst this may sound like a time consuming excersise it may be quicker and create a more robust solution.

If you want to try and troublshoot the issue you are seeing you can start by having a look through the following article which discusses upgrading project from versions earlier than Installshield 2012:
Upgrading Installshield Projects

In addition try logging your installer, after creation search the log for "Return Value 3", and then look above that to see if there is any information as to what has happened in the install:

How to log windows installer installation:
Windows Installer Logging


0 Kudos

As per your suggestion, I re created the project using InstallShield Professional 2019 Trial version and getting the same error with Windows 10 1903 version, but working with Windows 10 1809 version. Any suggestions?
0 Kudos

Hi @thomasxavier ,


Can you please provide/attach msi /windows installer log as @shunt  mentioned?That could help us give you more insights about the actual cause?




0 Kudos

Please see the attached file which has the ism file and the scripts used for ism file Thank You
0 Kudos

Hi @thomasxavier ,

Unfortunately i couldn't build the InstallShield project files that you had given since it has dynamic links & files that mightn't be available for me.

Possible causes from Microsoft article would be:


You may receive this error message if any one of the following conditions is true: 
  • Windows Installer is attempting to install an app that is already installed on your PC.
  • The folder that you are trying to install the Windows Installer package to is encrypted.
  • The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive.
  • The SYSTEM account does not have Full Control permissions on the folder that you are trying to install the Windows Installer package to. You notice the error message because the Windows Installer service uses the SYSTEM account to install software.

If not among those-please check these:

The following is a non-exhaustive list of known causes for this error:

  • Short file name creation is disabled on the target machine.
  • An Install Script custom action is prototyped incorrectly.
  • A file is locked and cannot be overwritten.
  • The Microsoft Windows Installer Service is not installed correctly.
  • The Windows Temp folders are full.
  • The setup was corrupted after installation and, therefore, fails with this error during un-installation.
  • An older version of Install Shield Developer is being used.
  • A general error occurred during the installation.
  • Print and File sharing is not installed or enabled when installing MSDE 2000.

If you could trace cause among these,you can find resolutions in below mentioned articles:




0 Kudos

Thank You Jenifer for you reply and efforts, I will check those mentioned in your reply Thomas
0 Kudos

We figured out the reason causing the issue. We have *.ocx file for 32-bit Office and for 64-bit, same name but different build, one for 32-bit and another for 64-bit. We were registering both of these files and everything was working while installing up to Windows 10 1803 OS installation. But during the installation on 1809 version, the installer hangs and NOT completing the installation. We figured out that the above mentioned registration of *.ocx file is causing the issue. What really happened was, we are registering the 32-bit .ocx file using the self-registration feature of the Component, in Windows 10 64-bit OS. This registration was failing caused the hang of installer. We removed the self registration and registered it through script using c:\Windows\SysWOW64\regsvr32.exe file the installer issue get solved. Now the 1603 error is no more showing up.

Thank You for your support 


0 Kudos