cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
sathees_r
Flexera beginner

Enable start application is not working in 32 bit machines when modifying the config(.ini) file

Hi,

We are using the Installshield 2014 professional to generate a MSI setup for 32/64 bit machines. Modified the printer's config file (.ini) to customize the options. We are using same printer configuration(.ini) files for both 32/64 bit drivers. In a 64-bit machines, everything is working fine as expected.  But in a 32-bit machines, only "Enable Start Application" option is disabled even it is enabled in the configuration file. Other configurations are applied properly and working fine. Same behavior happening in both win7 & win10 machines.

Configurations

; Start Application options

;Key name: Enable Start Application=<1 or 0>
;Enables or disables the "Start Application" option in the Printer Driver.
;If enabled, the user can specify an application that the driver should launch.
;The application can capture the printed document and parameters passed by the printer driver.
;Available for Printers: Color, ColorPlus, EMF, TIFF\Monochrome, PDF
;Available values:
;0: Disable the "Enable Start Application" option (default)
;1: Enable the "Enable Start Application" option
Enable Start Application=1

ApplicationPath=C:\Wepa\bin\WepaUploader.exe

Attached the screenshots and config file (WEPA-PDF-BW.ini) for your reference. Please check it.

Screenshots:

In 32-bit machine, the option is disabled - StartAppError32.png.

In 64-bit machine, the option is enabled - StartAppNoError64.png.

Looks like, the problem is in black ice side. So please help us to resolve this problem as soon as possible.

Thanks

Labels (1)
0 Kudos
2 Replies
Flexera banna_k
Flexera

Re: Enable start application is not working in 32 bit machines when modifying the config(.ini) file

Hi @sathees_r,

Looks like it is not an issue with the installer msi,  since msi is able to create the entries key values in INI file.

Can you debug your application and see why the ini configuration is not reflecting in your application.

Can you check by removing the white space in your key, and see it is getting reflected in your updated application. 

EnableStartApplication=1

  

0 Kudos
sathees_r
Flexera beginner

Re: Enable start application is not working in 32 bit machines when modifying the config(.ini) file

Thanks for the reply. The problem has been fixed automatically without any changes after upgraded the driver version.
0 Kudos