thomCblackwell
Flexera beginner

C++ 2010 runtime URL incorrect

Jump to solution

This just recently starting happening. Attempting to install a C++ 2010 x86 fails  with this error.

I have tried unchecking and re-adding this, so I am just  using the defaults. Any ideas?

2010.png

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
varul
Revenera
Revenera

Re: C++ 2010 runtime URL incorrect

Jump to solution

Else you can also try to change the prq setting from download from web to copy from source media or extract from setup.exe

Right click on VC++2010 and then select copy from source media options,

uncheck the prq from redistributables list and recheck it will ask for download click YES to download the redistributable file

The go to releases --> select setup.exe --> select Installshield prq location field

select follow individual selection or copy from source media

The save the ism and rebuild the project and install the setup and see it works.

View solution in original post

0 Kudos
7 Replies
thomCblackwell
Flexera beginner

Re: C++ 2010 runtime URL incorrect

Jump to solution
Ugh... well not sure what happened to the text of this post.. My installer redistributes C++ 2010 redistributable (x86). This has worked well for easily a month . Then all of the sudden I get these errors on install the redistributable is not on the machine. I tried removing it from my Redistributables and adding it back. Tried having it download from the web vs including it. I think the URL that InstallShield has has gone dead. Any ideas on how to fix this? Or am I on the wrong track?
0 Kudos
varul
Revenera
Revenera

Re: C++ 2010 runtime URL incorrect

Jump to solution

Hi,

  The issue due to the checksum values are changed from the new VC redist from windows, we have modified the prq files and it will work without any issue, Please download the attached prq files and replace with existing file in below or respective installshield installed path and then try again

C:\Program Files (x86)\InstallShield\2020\SetupPrerequisites

Hope it helps,

0 Kudos
thomCblackwell
Flexera beginner

Re: C++ 2010 runtime URL incorrect

Jump to solution

Hi,

Unfortunately, I replaced the .prq files as you described last week, and it seemed to work ( I reported that to Support).

But today users reported the problem is still happening.

Did something change again? Is there some way to force this to <work> no matter what? I don't care about the size of my Setup.exe etc. and I don't need to do worry about anything fancy other than - install it if its not there, do not install if it is.

Thanks!

 

0 Kudos
thomCblackwell
Flexera beginner

Re: C++ 2010 runtime URL incorrect

Jump to solution
Sure wish you could edit these... 🙂
I replaced the .prq last week built a setup.exe - handled the C++ 2010 X86 runtime fine. Built a Setup.exe today, users report the problem described at the beginning of this thread. So the bad behavior reappeared.
0 Kudos
varul
Revenera
Revenera

Re: C++ 2010 runtime URL incorrect

Jump to solution
Hi ThimCblackwell,

I have checked the prq files attached in above case comments, and im able to install VC++2010 without any issue, or install x64 or x86 version,

Please download the attached prq and replace in your redistributables list and then rebuild and try and check it works or not.
0 Kudos
varul
Revenera
Revenera

Re: C++ 2010 runtime URL incorrect

Jump to solution

Else you can also try to change the prq setting from download from web to copy from source media or extract from setup.exe

Right click on VC++2010 and then select copy from source media options,

uncheck the prq from redistributables list and recheck it will ask for download click YES to download the redistributable file

The go to releases --> select setup.exe --> select Installshield prq location field

select follow individual selection or copy from source media

The save the ism and rebuild the project and install the setup and see it works.

View solution in original post

0 Kudos
thomCblackwell
Flexera beginner

Re: C++ 2010 runtime URL incorrect

Jump to solution
Support helped me this morning. The does solve the problem. I had two mistakes.
I did not refresh the redistributables grid, this is important to do; the 2010 icon had a ! even after reopening the project. I also had set Copy from Source Media , which was in conflict with what I wanted to do (create a single .exe
0 Kudos