Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Build error 136 - Can't copy setup.exe

I created a project using IS2012 and successfully built and ran it. I found some issues and rebuilt it and ran it. Some more issues, and attempted to rebuild it a third time, but now I get an error: Could not copy file 'c:\users\af7421\appdata\local\temp\setup.exe' to 'I:\{my project name}\media\virtual CD\Disk Images\Disk1\setup.exe' "The system cannot find the path specified."

I have confirmed that both paths exist. I deleted setup.exe from the project file to confirm that there wasn't a file-in-use issue. I closed and reopened IS which didn't help. I read the KB article, which discussed error 136 only in the context of setup.inx, which was not helpful. I tried "Refresh build" which also got the same error. I also tried removing the Media\virtual CD folder to give IS a blank slate to work on, but that didn't help either.

A colleague with an IS license volunteered to run the build on his workstation, which was successful, but I'd prefer not to be dependent on him. Any suggestions on how to get the build to again run successfully on my workstation?
Labels (1)
0 Kudos
(1) Reply
Level 6

Try closing any Windows Explorer windows which you have used to view the directory where you build your setup Media. Having youe setup disk contents open in Windows Explorer does cause this kind of error.
0 Kudos