Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Basic MSI project Upgrade problem

I created a single image installation EXE for my project and its working fine, but when I updated the old files and regenerated the single image installation EXE with the same installation project.
When I installed this new EXE on fresh PC its working fine, but when I installed this on a PC, which is having the older version setup, then it asks for upgrade, then I selected the upgrade and installation is completed. But the new files are not updated in my system.

Pls help me....
Labels (1)
0 Kudos
(5) Replies
Level 5

I believe you need to add an upgrade item under the Media/Upgrades view.
0 Kudos
Not applicable

Are you planning for a major upgrade? You have to make sure below things for major upgrade install

1. For every major upgrade the upgrade code is same for old and new install.
2. For new install, you have to regenerate the product code and package code;
3. For new install, increment the product version.

I hope you know how to set major upgrade using InstallShiled, Let me know if you need more info;
0 Kudos
Level 8

I believe that I have a similar issue. It's not a major or minor upgrade but rather just another release/build that contains newer files.

The problem I have is REPAIR. When running this from Add/Remove Programs... my application reverts back to my previous install rather than repairing the one I just upgraded to. Seem like it has the previous version on the brain, in a matter of speaking.

I will post this as new and only put it here because of some similarities.
0 Kudos
Level 8

Still no resolution on this. I have a incident ticket with support but so far nothing they have had me do helps solve the problem.

Thought I would post again here to generate some discussion.

Fingers crossed.

0 Kudos
Level 8

Repair reverting to the previous version turned out to be a known issue! Updated the information in Add/Remove problems to not display Repair by default. Using the Change button instead. This has worked so far.
0 Kudos