cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
doowop
Level 2

Uninstaller issues and errors

I'm getting a strange error when trying to kick off the uninstaller for my application.


Installer: No 'sea_loc' in working directory, could not define $EXTRACTOR_EXECUTABLE$
Loading externalized properties
product was null
ZeroGb1: Unable to load product from registry. Product ID: 8afab831-1f00-11b2-b1
ff-a388e07f4799
at com.zerog.ia.installer.uninstall.DescriptorList.i(DashoA10*..)
at com.zerog.ia.installer.uninstall.DescriptorList.a(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.l(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.j(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
at com.zerog.ia.installer.Main.main(DashoA10*..)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(DashoA10*..)
at com.zerog.lax.LAX.main(DashoA10*..)
The uninstallation could not complete due to an error.


Does anyone know what could cause this? This is just the default uninstaller, I didn't add any custom actions to it yet.
Labels (1)
0 Kudos
2 Replies
TomCarey
Level 4

I'm getting same thing with 2011,
Did you ever get a response to this?

thanks
0 Kudos
weelyn
Level 5

just got this error too

I'm on a Mac, using IA2010, but not using a "Mac" setup, I generate an "Unix" setup to be able to use batch (silent) install (the usual Mac-friendly setup built by IA doesn't work in batch mode)

I'm pretty sure I've been able to use this uninstaller in the same conditions before...

---

I re-ran the setup to upgrade my product. This time, the Uninstaller worked.
I'm re-making a clean build of the setup to retry and see if it's a transient issue.

---

OK after a setup rebuild... I think all was not rebuilt on the first try, in fact.
0 Kudos