flex1234
Level 3

Starting tomcat

Hi,

After installation, I want to call a .bat file which resides in tomcat directory.

In Post-install, create an Execute Script/Batch File.

Then what command must be written to work this batch file?

I want to call startup.bat file under "apache-tomcat-6.0.37/bin/startup.bat" which resides under my install directory?

Thanks
Labels (1)
0 Kudos
9 Replies
RamyaVenkatesh
Level 7

Hi,

You could store the apache install location using an InstallAnywhere variable and then use that in the execute batch file action. Something like $APACHE_INSTALL_LOCATION$/bin/startup.bat
0 Kudos
flex1234
Level 3

Hi,

Apache is already included to the installation files. So the statement I wrote is below.

$USER_INSTALL_DIR$$/$_$PRODUCT_NAME$_installation$/$apache-tomcat$/$bin$/$startup.bat
0 Kudos
RamyaVenkatesh
Level 7

Yes, that should be fine, provided apache-tomcat is the actual directory you have apache installed. Are you facing any issues with that?
0 Kudos
flex1234
Level 3

Tomcat is portable. Actually when I double click on startup. bat command line appears and works fine (Normal behaviour: Command line window always appears ).

But with this command there is no window opening.When I investigate logs, it logs as Successful.

Am I doing something wrong?

You can simply test it with downloading tomcat (zip) from the link
http://tomcat.apache.org/download-70.cgi

Thanks
0 Kudos
RamyaVenkatesh
Level 7

After the installation is complete, check if apache tomcat service has started. I don't think it matters if the command line window opens or not. What is the exact issue you're facing?
0 Kudos
flex1234
Level 3

Service is not starting. Thats the exact problem.
0 Kudos
RamyaVenkatesh
Level 7

Ok. Is the CATALINA_HOME and JAVA_HOME set before you start the service?
0 Kudos
flex1234
Level 3

In installanywhere application, I did not set any of them. Is it necessary?

But the .bat file that I'm trying to work, includes these assignments.
0 Kudos
flex1234
Level 3

Also there is one more problem.

I'm creating a simple project and adding a readme.txt file into files. In post install I'm adding an execute file action. As target file, I'm choosing that readme.txt file. After installation there is no txt file opens.

Is it normal?

Note: I'm doing no other settings.
0 Kudos