cancel
Showing results for 
Search instead for 
Did you mean: 
bidyapatip
Pilgrim

Installer UI not taking keyboard input.

Recently we upgraded installer from 2009 to 2012.
We are seeing a weird behavior in "some" unix machine(using X window).

While installing the product created by using InstallAnywhere2012, it does NOT take keyboard input.
This happens only in some machine.

I could see the release notes of 2012 SP1:
IOA-000066700 When end users navigate between panels, the cursor is no longer positioned in
read-only locations on the Choose Install Directory panel or the Get User Input -
Advanced panel. Previously in some scenarios, the cursor was positioned next
to read-only text.

I thought may be it is similar issue, and tried upgrading to InstallAnywhere2012SP1.
But that did not solve the purpose.

Is it an issue in installer side? if not where should we look into for fixing it?
Labels (1)
0 Kudos
10 Replies
bidyapatip
Pilgrim

Re: Installer UI not taking keyboard input.

my current installer version is:

InstallAnywhere 2012
Version: 14.0
Build: 4390


PatchLevel:14.0_SP1_Enterprise with Cloud Pack
0 Kudos
bidyapatip
Pilgrim

Re: Installer UI not taking keyboard input.

Please provide your input.
0 Kudos
jerome_IA
Flexera beginner

Re: Installer UI not taking keyboard input.

I've seen similar issue when JRE was upgraded to 1.7. Is it your case in your new installer?
The behavior only occurs in X window.

--Jerome
0 Kudos
Highlighted
bidyapatip
Pilgrim

Re: Installer UI not taking keyboard input.

jerome_IA wrote:
I've seen similar issue when JRE was upgraded to 1.7. Is it your case in your new installer?
The behavior only occurs in X window.

--Jerome


Yes we have upgraded to JRE 1.7(InstallAnywhere2012).
We are seeing this issue in unix(solaris and AIX) or linux(red hat and suse) machine only. But not in Windows.
Most of the time we use Xmanager, but some of test engineer mentioned they used vnc client and found this issue.

One more thing to note, this issue comes only in few machines.
0 Kudos

Re: Installer UI not taking keyboard input.

Hi,

Could you please share the below information:

Are you creating the installer for linux or unix on Windows machine?
How are you connecting the linux or unix machine? Is it through putty?
Are you trying to connect the remote machine through putty or VNC?
Make sure the XManager on client machine is running.
Can you share the project file if possible.

Thanks,

Manzoor
0 Kudos
bidyapatip
Pilgrim

Re: Installer UI not taking keyboard input.

manzoor.matoo wrote:
Hi,

Could you please share the below information:

Are you creating the installer for linux or unix on Windows machine?
How are you connecting the linux or unix machine? Is it through putty?
Are you trying to connect the remote machine through putty or VNC?
Make sure the XManager on client machine is running.
Can you share the project file if possible.

Thanks,

Manzoor


Thanks a lot for the reply.

We are building installer in windows machine for windows platform and
building installer in linux machine for Solaris/AIX/Linux platform.

We are facing the issue in unix/linux in few machines and also not always. In fact sometimes it works in same machine.
I have seen the issue, when I access the remote machine through X manager.
But as per test engineer, they also seen it when remote machine is accessed through VNC client.

When the problem reproduced, I tried keyboard input with other Applications, they work fine. (other applications in remote unix/linux machine)
In fact, I could open the "default left-top corner menu provided by X window"(of same installer window) using Alt+Space.


I am sorry, I can not put the project file here as it is too large and also my organization may not allow to do so.
Important thing is, it works in many machines and even same machines. I don't think, any thing related to iap_xml script has problem.

I will be waiting for more input from your side.
Thanks in advance.
0 Kudos
pv7721
Flexera beginner

Re: Installer UI not taking keyboard input.

I think this might be a Java-related issue. Have you been able to solve it?
0 Kudos
jerome_IA
Flexera beginner

Re: Installer UI not taking keyboard input.

For the record, the java issue is http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7147075

This will be fixed far far away in JRE/JDK 8 ...

Edit: Hum, they will hopefully backport it in 1.7u40

--Jerome
0 Kudos
jdonovan
Pilgrim

Same problem

I'm noticing the same thing with my IA2012 project on linux. I have an upgraded project (from IA2011 to IA2012SP1). We are using jave 1.7U10.

It seems to happen more on RHEL6 than a RHEL 5

Anyone find a workaround?

Thanks
0 Kudos