cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jcrphx
Level 3

IA2008-enterprise "Install Log" file is not generated.

I am needing help to figure out what is wrong in my setup that is not generating the "Install Log".

_How I am activating the "Install Log" feature in my IA2008 setup?

Go to : Project|Info|Installation log

Checkbox: Generate install Log during installation (Enabled) using (Plain text format).

Note: I can see that the variable
$INSTALL_LOG_DESTINATION$ is setup properly. I means is including the "USER_INSTALL_DIR+Product_Name+Installlog.log" but the "log" file is not created physically in my file system.
Labels (1)
0 Kudos
5 Replies
ajtarter
Level 2

Are you looking for the log file before or after you exit the installer? It is not written until the installer exits.
0 Kudos
jcrphx
Level 3

Yes the install.log file suppose to be created "after" the installation.
0 Kudos
jcrphx
Level 3

I am still trying to figure out why the install.log file is not created considering that this option is enabled in my project. Seems like under some situation this important feature stop to work......looks like there is a bug.
0 Kudos
pv7721
Level 20

Would it be possible for you to post your project?
0 Kudos
nosrednayduj
Level 7

I want to change the name of the install log. So, in post install, I set $INSTALL_LOG_DESTINATION$ to something other than would be generated by $PRODUCT_NAME$. No log is created. I made a VERY SIMPLE project as example by deleting all the steps from another project. I'll try to attach it; you'll have to rename it. (Hey, why isn't .iap_xml a valid attachment type? I mean, given the topic of the forum?) I tried setting this in both pre- and post-install; no help. Of course I have to set it AFTER all the panels, because I want to set it to $USER_INSTALL_DIR$...
0 Kudos