Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Error setting uninstaller icon

Hi All,

The icon for our uninstaller executable has stopped showing up.

When we run the installer, we see the error:
Install Uninstaller: (Install All Uninstaller Components)
Additional Notes: WARNING - Could not change the icon for the executable. Reason=Cannot run program "C:\Users\Administrator\AppData\Local\Temp\2\I1314296136\Windows\resource\IconChng.exe": CreateProcess error=14001, The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

Anyone seen this before?

We're using IA 2011 Enterprise, SP1.

Labels (1)
0 Kudos
(3) Replies
Level 3

I too experienced this problem when trying to run our installer on Windows Server 2008 R2 64-bit. I believe this was not a problem on most of the other Windows versions I tried though. What Windows version are you seeing this error on?

I submitted an incident a while back to Flexera support and a support rep informed me that this is a bug in their software. Here is part of their response:

This problem has been reproduced and determined to be an issue in our software. This issue has been submitted to our Engineering team as Issue #IOA-000064015. Currently, there is no workaround.

Our Engineering team is investigating this issue, but at this moment, there is no estimated time frame for when it will be fixed. You can track the status of this issue by checking product release notes or searching our Knowledge Base through eService.
0 Kudos
Level 3

With linux 64bit installer I get rid of this message by renaming "...Windows\resource\IconChng.exe" file to lowercase "Iconchng.exe".

So it looks like a simple string case bug. I am running same configuration on Windows server and don't have problems there.
0 Kudos
Level 2

I had the same error yesterday when I decided to change the icon for my uninstaller component. After checking the Windows application event log I saw that it was complaining about a missing MVC90 assembly. This is from Visual Studio 8. I manually installed the redist package from VS2008, then reran the installer without error. I then uninstall the redist package (from add/remove programs), added the redist package to the very beginning of my installer sequence, and was able to run the installer without error.

My installer is built on Windows for Windows and Linux.

Make sure to add a "/q" to the action that executes the installer so the user doesn't have to answer questions about the vc redist installation
0 Kudos