bsivakumar
Flexera beginner

Delay starting vendor daemon

I have installed v11.13.1.2 and noticed that in few of the system the vendor daemon process takes time to start [30-60 seconds]. This doesn't happen in few machines. Appreciate any insight as to what can be causing this delay.  

5:48:24 (lmgrd) (@lmgrd-SLOG@) === Startup Info ===
5:48:24 (lmgrd) (@lmgrd-SLOG@) Server Configuration: Single Server
5:48:24 (lmgrd) (@lmgrd-SLOG@) Command-line options used at LS startup: -l /genesys/logs/FlexLM/11.13.1.2/FlexLMLog_2021-03-19_05:48.log -c /genesys/gcti/FlexLM/11.13.1.2/FLEXLM-NODE-302.dat
5:48:24 (lmgrd) (@lmgrd-SLOG@) License file(s) used: /genesys/gcti/FlexLM/11.13.1.2/FLEXLM-NODE-302.dat
5:48:24 (lmgrd) (@lmgrd-SLOG@) ===============================================
5:48:24 (lmgrd) Starting vendor daemons ...
5:48:24 (lmgrd) Using vendor daemon port 7261 specified in license file
5:48:39 (lmgrd) The TCP port number in the license, 7261, is already in use.
5:48:39 (lmgrd) Possible causes:
5:48:39 (lmgrd) 1) The license server manager (lmgrd) is already running for this license.
5:48:39 (lmgrd) 2) The OS has not "cleared" this port since lmgrd died.
5:48:39 (lmgrd) 3) Another process is using this port number (unlikely).
5:48:39 (lmgrd) Solutions:
5:48:39 (lmgrd) 1) Make sure lmgrd and all vendor daemons for this
5:48:39 (lmgrd) license are not running.
5:48:39 (lmgrd) 2) You may have to wait for the OS to clear this port.
5:48:39 (lmgrd) Retrying for about 5 more minutes
5:48:57 (lmgrd) Still trying...
5:49:09 (lmgrd) Started genesys.d (internet tcp_port 7261 pid 42924)
5:49:09 (genesys.d) FlexNet Licensing version v11.13.1.2 build 173085 i86_lsb

0 Kudos
4 Replies
mrathinam
Revenera
Revenera

@bsivakumar  The logs saying clearly why it delays starting "The TCP port number in the license, 7261, is already in use." and the remaining message also saying in details.  

0 Kudos

Yes , but when I run netstat -tuplen I don't see the port in use . here is what i did 

 

1. Stopped the flexlm

2. checked in command if post was is in use . netstat -tuplen  didn't return anything 

3. started the flexlm 

4. ran the command netstat -tuplen continuously and the port was not assigned for 30-60 seconds 

Even though the log says this error I am not sure if this issue is related to TIME_WAIT.  Hope this clarifies 

0 Kudos

$ netstat -tuplen | grep 7261
tcp6 0 0 :::7261 :::* LISTEN 140112 21874115 41988/genesys.d

$ service flexlm stop
Redirecting to /bin/systemctl stop flexlm.service
$ netstat -tuplen | grep 7261
$ netstat -tuplen | grep 7261

$ netstat -tuplen | grep 7261

As you can see the 7261 port is not active. 

0 Kudos

You can run the command "sudo lsof -i -P -n | grep LISTEN" and check the status of the port in order to be sure. Also to eliminate the possibility of the port being active you could specify a different port number for the vendor daemon and lmgrd in the license file  as below ,crypt the file and  start the license server once again and observe the logs.

SERVER my_server 17007ea8 1700

VENDOR demo PORT=27006

Note: Make sure the port is not being blocked by the firewall.

0 Kudos