- Revenera Community
- :
- FlexNet Operations
- :
- FlexNet Operations Knowledge Base
- :
- 'notFoundEntity' Error seen while searching for devices (On-Prem)
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
'notFoundEntity' Error seen while searching for devices (On-Prem)
'notFoundEntity' Error seen while searching for devices (On-Prem)
Symptoms:
When clicked on any "Device" we see the error stating: "notFoundEntity".
Flexnet.log shows:
2021-08-09 16:58:28,400 [default task-57] ERROR (fnofacade) [ADMN] Dao Error : BaseProductDAOImpl 2021-08-09 16:58:28,400 [default task-57] ERROR (lfs) [ADMN] notFoundEntity
Diagnosis:
This is a data issue where LFS is using the base_product_id which is removed on the FNO side.
All the devices which don't have BASE_PRODUCT_ID set in LFS_HOST table are getting the BASE_PRODUCT_ID from LFS_HOST_TYPE.
Find the base_product_id here.
But that BASE_PRODUCT_ID is removed in the FNO database (EMB_BASE_PRODUCT table) causing the error message 'NotFoundEntity' for all of the devices that have this base_product_id.
Solution:
Remove this base_product_id from the LFS_HOST_TYPE table:
update lfs_host_type set base_product_id=null where base_product_id='<ID>'