Summary
"Invalid Login Response" error after installing Cognos Analytics
Symptoms
This document provides steps to resolve "Invalid Login Response" error after installation of Cognos Analytics while accessing any reports via the URL.
Cause
This error is shown as a result of using "Easy Install" method and not choosing the "Optional Gateway" during installation.
Resolution
To resolve this issue, uninstall Cognos first, then re-install it. When following the instructions for installing Analytics in the "Installing FNMS 2017 R3 on Premises.pdf" document on page #58, the required Cognos Gateway is not installed.
On the "Install type" dialog, instead of the "Easy install" radio button, please select "Custom install". On the subsequent dialog "Choose components", both the checkbox for "Application services" as well as the checkbox for "Optional gateway" MUST be selected.
Additional Information
In addition to the above, please also check the CognosConfigProperties.xml file :
---
<!--
Content store database settings
-->
<!--
ContentStore database location.
When using TCP, the format for this value is hostname:port.
Alternatively, the hostname\instancename format (without a port) can be used.
-->
<property name="ContentStoreDatabaseLocation" value="
abcdefgh"/> <!--Required-->
<!-- ContentStore database name. This database must already exist. -->
<property name="ContentStoreDatabaseName" value="ContentStore"/> <!--Required-->
--
The ContentStoreDatabaseLocation value should be "hostname:port" or "hostname\instancename" whereas the configured value only shows the hostname "
abcdefgh".