Some users may have issues creating a community account See more here.

daniel_klein
Active participant

SLES for SAP recognition

Hi all,

do anyone knows how the Inventory Agents detects however SLES for SAP is installed or not?

We are facing the issue that the Inventory Agent recognize SLES for SAP sometimes correct and sometimes just as SLES. I am not sure, but it seems that the agents uses the name value in the os-release at a SLES Server to determine if it is a SLES for SAP or not. That would explain why just recognize 1/3 of the SLES for SAP. Because Suse rewrites this value sometimes. You find details in this KB article:

It also says that /etc/products.d/baseproduct should be use for recongnition

Has anyone experiences with this kind of recognition or knows how the recognition works for SLES for SAP?

Thanks

Daniel

Labels (1)
3 Replies
daniel_klein
Active participant

forgot to insert the link 🙂
https://www.suse.com/support/kb/doc/?id=7023490
0 Kudos
mfranz
Trusted advisor

Hi Daniel,

There are ususally 2 areas where the OS is involved. 1) The text field for each inventory (ComplianceComputer) and 2) the actual application.

For Windows, at least the way this data is import differs. For 1) just a string is copied over, for 2) a set of WMI evidences is imported and processed.

I can only assume that it is some kind of "pseudo WMI" for application recognition (2). Not sure where data is taken frmo for 1). It would certainly help to have a look at 2 inventory files (ndi), ideally both of the cases you described, and then try to trace it from there.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
daniel_klein
Active participant

Thanks @mfranz i'll check the ndi files as soon as we run our next datacenter inventroy and come back with the resulst.

0 Kudos