Build Warning 9580

Build Warning 9580

Symptoms:

When you are building an InstallShield MSIX project, the following error may occur:

warning -9580: This package has services configured. Hence, updating TargetDeviceFamily versions to minimum supported operating system version (Windows 10, version 2004, build number 19041).

Diagnosis:

Windows 10, version 2004, introduces support for running an MSIX package that includes services. Hence Target Device versions will be updated automatically by InstallShield if MSIX package contains NT service (windows.service extension). 

Solution:

This warning can be ignored if no changes are required for TargetDeviceFamily versions defined in the manifest file. To override default behavior, configure ‘Include Desktop Extensions’ property in Releases view as required.

Labels (1)
Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Sep 03, 2020 06:46 AM
Updated by:
 
Contributors