cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Build Warning 9578

Build Warning 9578

Symptoms:

ISDEV : warning -9578:  Services configured with dependencies outside the MSIX package are not currently supported by Microsoft. '%1' is not a valid Dependency Service.

%1 is a placeholder that contains the dependency name (referred as part of windows.service extension) causes this warning.

App Installer may throw weird error if definitions for dependency service names are not included as part of MSIX package. 

Diagnosis:

This build warning is shown when Dependency Services are configured in windows.service extension and the same is not included as part of the MSIX package. Windows 10, version 2004, introduces support for running an MSIX package that includes services and this release currently does not support services with dependencies outside the package.

Solution:

One or more of the following steps resolve the issue:

  • Remove either dependency names or create new windows.service extension for referred dependency service name.
  • Check Microsoft latest documentation on MSIX services and see if this limitation is addressed in the latest release.
Labels (1)
Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Sep 03, 2020 06:32 AM
Updated by:
 
Contributors