cancel
Showing results for 
Search instead for 
Did you mean: 
jophyjob
Pilgrim

"launch application" after install in installshield silent setup " /s /v/qb" ?

Hello all ,
We created one setup project and we have auto update option in the project . For that we like to use silent install . when we install normally in give option to launch application after install and we click finish it will start application , but wen we run it from CMD in silent mode it not starting the application after install . CMD parameters that we using are " setup.exe /s /v/qb " . can you provide any solution for this problem .

with regard ,
jophy
0 Kudos
3 Replies
Flexera chiranjeevi
Flexera

Try scheduling an .exe custom action to run in silent mode

Hello,

Have you scheduled any custom action during silent install to launch the application after setup completes?
In the silent mode User Interface dialogs are skipped. So the custom actions set to be launched after other UI dialogs are also skipped. Due to this silent install will not launch the application after successful installation.

Try scheduling an .exe custom action to run in silent mode, for that you have to sequence them so that they are not associated with a dialog. In other words try any of the following locations:

- After File Transfer
- After COM Registration
- After Register Product

I recommend the last because that's pretty much after the setup is done with all the file copying and registering.

Thanks,
Chiranjeevi
0 Kudos
Highlighted
jophyjob
Pilgrim

Re: "launch application" after install in installshield silent setup " /s /v/qb" ?

Hello chiranjeevi,
When install we use default option in the installshield to launch the application (Set by radio button in setting window) .

But when we write custom action to start application , run from normal mode it will start two time (from custom action and normal check option). How to identify from which mode it is running in custom action .

with regards
jophy
0 Kudos
Flexera chiranjeevi
Flexera

Re: "launch application" after install in installshield silent setup " /s /v/qb" ?

Hello

You should create the condition for the CustomAction based on the
UILevel property to specify the mode in which it should run.

Please refer below link:

http://msdn2.microsoft.com/en-us/library/aa372096.aspx

Hope this helps.


Thanks,
Chiranjeevi
0 Kudos