cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

.prq reference confusion causes streaming error during build

I am migrating my build system from Windows Server 2008 to Windows Server 2008 R2.
I have installed 2012SPRINGSP1 SAB on the new machine the same as it was on the old machine.
I have a package that uses a prerequisite installer for Microsoft Report Viewer 2010.
The Microsoft Report Viewer 2010.prq refers to the bootstrapper file relative to the ISProductFolder.



However, when I run the IsBldCmd I get the following
ISDEV: An error occurred streaming 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\ReportViewer10\ReportViewer.exe' into setup.exe

Since there is no 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper' folder it obviously can't find it.

My question is, why is it looking for it there and not in \SetupPrerequisites\ReportViewer2010 ?

The IS 2012SP1 SAB is installed in the same path on the new machine as on the old. I've copied the contents of the SetupPrerequisites folder from the old machine to the new machine.
Where is it getting the 'C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\ReportViewer10' path from anyway?

Any help would be appreciated.

Richard
Labels (1)
0 Kudos
2 Replies
Highlighted

Re: .prq reference confusion causes streaming error during build

I've discovered where the "C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\ReportViewer10\ReportViewer.exe" path is coming from.

It turns out that there are 2 ReportViewer prq definitions in the SetupPrerequisites folder. The IDE shows "Microsoft ReportViewer 2010". I assumed that this was the name of the prq file as there is a prq file named "Microsoft ReportViewer 2010.prq". However in my folder there is also a file named "Windows Report Viewer 2010.prq". Within this file I found that the localpath attribute was set to ... "C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\ReportViewer10\ReportViewer.exe"

I changed the value to LocalFile="<ISProductFolder>\SetupPrerequisites\ReportViewer2010\ReportViewer.exe" and reran the build and it works.

Now the only question is why when I reference "Microsoft ReportViewer 2010" (as it shows in the IDE) is it apparently using the "Windows Report Viewer 2010.prq" definition? I checked the old build server and it had both prq files with the invalid LocalFile path in the "Windows Report Viewer 2010.prq". I've been building there successfully for months.

I looked at the content of the prq files to see if there was an internally defined name that appeared in the prerequisites list that might be different than the file name. There was none. Besides the IDE on my development machine shows both prq versions.

I now have a solution but I still have questions.

Richard
0 Kudos
Highlighted

Re: .prq reference confusion causes streaming error during build

Hi there,

If you add any prerequisite to an setup by browsing the prq file then the path will be changed,
and if you want the path to install shield prerequisites folder than copy that to the prerequisites folder .
And it will even show you the message regarding the same.
0 Kudos