[Incident]: Some users report they are unable to access the case portal. Please see this community notice for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Awolf401
Level 4

.net framework 3.5 sp1

The software that I am creating this install for requires the latest and greatest .net framework and it needs to be downloaded as we are distributing this install remotely and the .net packages is bigger then 200 mb. Right now I have it working through a .prq in a basic msi project. The problem is that when it goes to install it takes forever.(over an hour) And I am using a pretty typical buisness broadband connection for those of you wondering if I am attempting this over dial-up. Is there anything I can do to speed it up?

Secondly I am trying to have them wait to restart till the end of the install. I have the /noreboot tag in the prq file to keep from having to reboot after words. However, I still get a yes/no dialog box that asks me if I want to reboot. Yes will reboot and no will stop the install.


Any help would be appriciated

(Always impressed with the help on this forum)
Labels (1)
0 Kudos
11 Replies
schmoli
Level 6

If it helps i'm at 30+ minutes installing 3.5sp1 on a vista machine (and I had the installer on the local network so that's not even downloading it)... oh just finished this second, about 33 minutes. It's not a fast install by any means.
0 Kudos
Christopher_Pai
Level 16

The 200+mb is more for media distributions. You want to use the internet bootstrapper download version that's 2mb initially then 60mbs deferred typically.
0 Kudos
Awolf401
Level 4

Forgive my newbness but can you provide the url for the prq file. Im not quite sure how to get my hands around it.

Thanks
0 Kudos
Christopher_Pai
Level 16

Google ".net 3.5 sp1 installshield" and the first hit is:

http://kb.acresso.com/selfservice/viewContent.do?externalID=Q200284
0 Kudos
Awolf401
Level 4

Man I knew that was Newb question I should have known that 😞

Sorry for that but I really do appriciate the help. I hope I can return the favor one day.
0 Kudos
cbarlow
Level 7

Why is the InstallShield .NET 3.5 redistributable object 200 MB when the Microsoft .NET redistributable is only 2 or 3 MB? I don't want our users to have to have an internet connection to install, but I also don't want to add 200 MB to the install package. Is my only option then to add the Microsoft installer to my installation and run it using InstallScript functions?
0 Kudos
Christopher_Pai
Level 16

cbarlow wrote:
I don't want our users to have to have an internet connection to install, but I also don't want to add 200 MB to the install package.


That's really the crux of the problem, right?

On my blog, I complained about the size of the framework and certain Microsoft employees claimed that I was exaggerating the size of the framework.

The reality is Microsoft only has two out of the box solutions

1) Super small bootstrapper with internet connectivity dependency

2) Super huge mondo package that can install everything on anything regardless of previous state.

If you want something in the middle, you have to make huge assumptions on what they already have and what hardware platforms they might be running. If you can do that, then you can extract the mondo and carve out the pieces you think you'll never need.

Or you can possibly use the new client profile pattern but that has serious issues.

Eitherway, the problem is with Microsoft here, not InstallShield.
0 Kudos
cbarlow
Level 7

So are you saying if I download the .NET 3.5 redistributable from Microsoft's website (2.7 MB) and install it with the rest of our program files, and then launch it using LaunchAppAndWait() that it still requires an internet connection?
0 Kudos
Christopher_Pai
Level 16

0 Kudos
Japster24
Level 6

I'm continuing to get the following message after the Microsfot .NET framework 3.5 SP1.prq file is run:

"The installation of the Microsoft .NET Framework 3.5 SP1 appears to have failed. Do you want to continue the installation?" [Yes/No buttons]

I don't want this dialog to appear b/c I know that it is installing succesfully (i ran the framework install with the GUI and it said it did). How do I fix this so this dialog will not come up?

Thanks!
-jp
0 Kudos
dmodiwirijo
Level 3

same problem here.:(
0 Kudos