cancel
Showing results for 
Search instead for 
Did you mean: 
shahidebryx
Pilgrim

converting from installShield 5.1 to installShield 2010

hi guys,

i am newbie here, i need to migrate from installshield 5.1 to 2010.

i downloaded version 2010 professional edition. when i opened installshield5.1 project file with installshield2010, it asks to convert to 2010. On choosing YES, it converts successfully.

Later i compiled the project which resulted into numerous ERRORs and Warnings.

Please suggest any solution or helping article/document.

thanks in anticipation

---
shahid
Labels (1)
0 Kudos
3 Replies
RobertDickau
Pilgrim

Re: converting from installShield 5.1 to installShield 2010

For a start, please see the topics under Getting Started > Upgrading from Earlier InstallShield Versions > Upgrading Projects Created with InstallShield Professional, esp. Migrating from InstallShield Professional 5.x.
0 Kudos
shahidebryx
Pilgrim

Re: converting from installShield 5.1 to installShield 2010

thanks Robert,

well i have already considered that document "Migrating from InstallShield Professional 5.x ".

But there is an other issue which is not address in that document.
Its DAO.h file. when i compile code, an err is reported as " can not open include file DAO.H " .

Later i searched for DAO.h (from IS 6.1 installed directories) and placed it into ScriptFiles along with DAO.rul

Now on compiling again it reported errors " unable to open include file "odbc.h".

To handle this problem, i simply commented lines
#include "odbc.h" and #include "odbc.rul" from DAO.h and DAO.rul respectively.

this way i was successful to compile to project.

But as i Build CDROM, it fails with error message "it says platform not supported"
0 Kudos
Marwan
Pilgrim

Re: converting from installShield 5.1 to installShield 2010

Look at the CDROM Platforms release property and see if Windows 9.x is set. Also, look in the General Information View and verify that no specific Windows 9.x is specified. Those platforms are not supported anymore and removing them from the project/release setting should fix the error you are seeing.
0 Kudos