Revenera Documentation site will be unavailable on July 2nd due to scheduled maintenance. For more information see the status dashboard.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
TimoZimmermann
Level 5

Windows 8.1 Environment variable not available until reboot / logoff-logon

I have a Basic MSI installation project and in this package I install a new system wide environment variable (in the attached example it’s named MYTEST with value 1).
Normally (on Windows NT, 2000, XP, Vista, 7, 😎 the new variable is immediately available for a new process (e.g. command prompt) which will be started directly after the installation finished.

But with Windows 8.1 (I tried the x86 version) the variable will be installed and is visible in the windows dialog where you can modify these variables (see screenshot) but it is not visible for new started processes until I reboot or make a logoff and Login!

That is a complete new behavior. Is this a bug or a feature and how can I avoid the reboot under a Windows 8.1? Must I change all older setups to work with Windows 8.1?

P.S.
Creating the variable not with msi but directly in the windows dialog for editing the environment variables, then the new variable is immediately available for new processes without a reboot.
Labels (1)
0 Kudos
2 Replies
mukeshsha
Level 2

Hi,
I am also facing the same problem on Windows 2012 for one of my Basic MSI installer. I also tried the code mentioned on http://helpnet.installshield.com/installshield18helplib/GetresEnv_variable_example.htm but no help.

Is there anyone who has fixed the problem?


Timo Zimmermann wrote:
I have a Basic MSI installation project and in this package I install a new system wide environment variable (in the attached example it’s named MYTEST with value 1).
Normally (on Windows NT, 2000, XP, Vista, 7, 😎 the new variable is immediately available for a new process (e.g. command prompt) which will be started directly after the installation finished.

But with Windows 8.1 (I tried the x86 version) the variable will be installed and is visible in the windows dialog where you can modify these variables (see screenshot) but it is not visible for new started processes until I reboot or make a logoff and Login!

That is a complete new behavior. Is this a bug or a feature and how can I avoid the reboot under a Windows 8.1? Must I change all older setups to work with Windows 8.1?

P.S.
Creating the variable not with msi but directly in the windows dialog for editing the environment variables, then the new variable is immediately available for new processes without a reboot.
0 Kudos
TimoZimmermann
Level 5

After some Windows Updates the problem was gone and never occured...
0 Kudos