cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nssoft-lagrange
Level 3

When an installshield express project is loaded in the solution, SetSite failed for package [Shared Web Components] (in VS 16.4.3)

Hi everyone,

This problem came with the last visual studio update, and I’m now unable to publish an asp.net core 3.1 app.
Please note that I’m unsure if this is related to VS 16.4.3 : it can be related to the fact that there was an update, whatever is the update.

Errrors :

When I right click > publish, I now got a null reference exception.

On solution load, i got these errors :

 

SetSite failed for package [Shared Web Components]
Source: 'EnvDTE' Description: La méthode ou l'opération n'est pas implémentée. System.NotImplementedException: La méthode ou l'opération n'est pas implémentée.
à EnvDTE.ProjectItems.get_ContainingProject()à Microsoft.WebTools.Shared.VS.ToRemove.VsHierarchyItem.get_Project()
à Microsoft.WebTools.Shared.VS.ToRemove.VsHierarchyItem.get_IsWebSiteProject()
à Microsoft.WebTools.Shared.VS.VisualStudio.IVsHierarchyExtensions.IsClassicWebProject(IVsHierarchy hierarchy)
à Microsoft.WebTools.Shared.VS.VisualStudio.Wrappers.VsSolutionWrapper.GetProjects(Boolean dotnetOnly, Boolean includeUnloadedProjects, Boolean webOnly)
à Microsoft.WebTools.Shared.VS.VisualStudio.Wrappers.VsSolutionWrapper.GetWebProjects()
à Microsoft.WebTools.Shared.VS.WebPackageLoader.EnsureRequiredPackages()
à Microsoft.WebTools.Shared.VS.WebCommonPackage.<InitializeAsync>d__7.MoveNext() 
--- Fin de la trace de la pile à partir de l'emplacement précédent au niveau duquel l'exception a été levée --- 
à System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
à Microsoft.VisualStudio.Shell.AsyncPackage.<>c__DisplayClass20_0.<<Microsoft-VisualStudio-Shell-Interop-IAsyncLoadablePackageInitialize-Initialize>b__1>d.MoveNext()

 

Same on webpublish, scaffoldingvs, eureka…
The more I try to help, the more packages start to fail…

What I tried :

  • Removing all publish profiles, as other posts on the same issue show that this could be an issue
  • Repair visual studio, and reboot the pc
  • check the csproj, didn’t find anything usefull like UNC path. There are relative path but nothing to be worried <ProjectReference Include="…\NSSOFT.Interop.App\NSSOFT.Interop.App.csproj" />
  • same for the .sln
  • removing webdeploy, clickonce… more package failed. Then adding it back, new packages still fail…

Installshield express
I finally found some interesting insights :
If I unload the installshield project from the solution, and restart visual studio, then the packages load fine and the publish work fine.
If I load the the installshield project, then restart visual studio, then the issue come back.

Is there something you can do so I can keep both install shield project and project deploy in the same solution ?

Thanks

This message has also been posted in microsoft bug tracker :
https://developercommunity.visualstudio.com/content/problem/900393/when-an-installshield-express-project-is-loaded-in.html

Regards,

Labels (1)
0 Kudos
0 Replies