cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MichaelHu
Level 5

Strange COM Data Extraction issue

Dear all!

I'm really experiencing some strange COM Data Extraction issues...

I just created a test-project with my DLL-file and all of its dependend files (all separate components). The dependent files are *.bpl files from borland.

Now here's what i do:

1. After i created all the components i choose to Extract COM Data from the DLL file and everything works perfectly!

2. BUT: If i close the project, reopen it and do the above step again nothing happens. And here's the funny thing: if I delete any of the dependent files and readd it, COM Extraction works again...... Until i close the project and reopen it....

Has anybody experienced this behaviour before??

Michael
Labels (1)
0 Kudos
3 Replies
MichaelU
Level 12 Flexeran
Level 12 Flexeran

Perhaps it's a matter of the process's current directory? Try creating a new shortcut to InstallShield with the directory those files are in and let us know if it fixes it. Another thing you could try is registering the dependencies on the machine before trying to run COM extraction.
0 Kudos
MichaelHu
Level 5

Michael you're a genius!

IT WORKED! 🙂

I just created a shortcut to the InstallShield-EXE and set the "Start in" directory to the path of my setup-files.

Do you think there will be a hotfix for this issue?
0 Kudos
MichaelU
Level 12 Flexeran
Level 12 Flexeran

I'm glad changing the directory worked for you. Until I know more about why this is a problem, I can only guess as to a hotfix, and this hasn't come up much. Is it possible that the DLL or EXE you are COM extracting is loading its dependencies in an unusual fashion?
0 Kudos