cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
khteoh
Pilgrim

Some files not installed sometimes

Hi, I encountered a situation where some files were not installed sometimes during InstallFiles action. The files were under component (A) which has the same condition/configuration as component (B). The files in component (B) would always be installed as expected but those in component (A) might not be installed sometimes. When this happened, the log file didn't capture any information about component (A) at all. Is there any place that I should look at / debug? Thanks.
Labels (1)
Tags (1)
0 Kudos
7 Replies
Highlighted
Georg1
Pilgrim

Re: Some files not installed sometimes

Do you have multiple features and A belongs to a feature which wasn't selected/installed, and B is assigned to another feature which is?
0 Kudos
Highlighted
khteoh
Pilgrim

Re: Some files not installed sometimes

Hi Georg1. Yes, both components are in the same feature. I missed out another information in my previous post... The problem occurred when the installation was repeated without uninstalling the previous one. Which means, right after I installed the software, without uninstalling it, I made another same installation again. The difference between the first installation and the second installation was that, a flag was unset in the first installation to exclude component A and component B and, in the second installation, the flag was set to true to include component A and component B. Problem: The files in component A were not installed but the files in component B were installed in the second installation.

If I uninstall the software and reinstall it with the flag set to true, I could get both components installed correctly.
0 Kudos
Highlighted
Georg1
Pilgrim

Re: Some files not installed sometimes

For the 2nd installer where you fixed the flag, did you change the product version in "General Information" tab? If not, consider doing so (one of the first 3 parts not the 4th)
Additionally there is a setting in the component to "Reevaluate Condition"

At least both of this together I use to remove files from outdated components during update installation, so it should work for you as well. But it doesn't explain your behavoir, I would expect none of your both components to install on second time.
0 Kudos
Highlighted
khteoh
Pilgrim

Re: Some files not installed sometimes

Hi Georg1. In the 2nd installation, where I set the flag to install both components, I didn't change the product version in "General Information" tab as it will be updated to the intended version automatically. In fact, both installations are expected to use the same version#.

About setting the components to "Reevaluate Condition". I have tried this. The results were that
1) If this is set to 'No', both were not installed in the 2nd installation.
2) If this is set to 'Yes', same problem occurred: The files in component A were not installed but the files in component B were installed in the second installation.
0 Kudos
Highlighted
ryanhopkins
Pilgrim

Re: Some files not installed sometimes

Same issues here. Some files were not installed sometimes during InstallFiles action.
192.168.0.1
0 Kudos
Esmebuckner
Pilgrim

Issue

I am also facing this issue anyone here who knows the correct answer then please help me.
christian new year quotations
0 Kudos
Highlighted
Nick_Umanski
Flexera beginner

Re: Some files not installed sometimes

This is a very poorly worded description, please elaborate, are you trying to upgrade or not. Have you Spun the correct GUIDs and Version number fields, did you create an Upgrade item. Do the individual files have version numbers and if so have they changed between each installation. If this is a Major Upgrade what "Major Upgrade Settings" policy have you set?
0 Kudos