Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

Small Patch takes a long time

I am creating a patch for a large MSI which has over 48,000 files.

The problem I have is a patch for this even a very small patch hangs with no status for a long time.

In order to narrow down the problem, I took out the custom actions, custom dialogs and simplified out install. I saw the same problem.

Since nothing custom in the install was causing the problem I had to determine whether this was an InstallShield\MSI problem or something we did with our install. I created a simple install.
this is a simple install with custom actions it has one dynamic link with 48,000 files. I created a patch for the simplied install and saw the exact same behavior.
From the log
Action start 8:50:09: ExecuteAction.
MSI (s) (D4:B0) [08:58:27:624]: Final Patch Application Order:

9 minutes of Nothing

In the real install this is more like 20 minutes

I tried setting the OptimizedInstallMode to 1 in the direct editor, but nothing.

Any ideas?
Labels (1)
0 Kudos
(3) Replies
Level 11 Flexeran
Level 11 Flexeran

I'm having the same issue now.

Do you know if this is normal?
Did you find out a solution?

0 Kudos
Level 7

Is you command line for the patch set to REINSTALL=ALL?

I'm taking a guess, but could this be your problem?

Can you not target a particular feature to be patched, hence saving the windows installer checking everything before it patches.

What does your log show, at which point is it hanging (or busy doing something)?

Is this the first patch you're applying to the base product?
0 Kudos
Level 11 Flexeran
Level 11 Flexeran

Hi Vijay__K,

Yes, the REINSTALL=ALL, and this is the first patch for the product.

But after a while it worked, it took about 25 minutes, but not being used to wait that long with InstallShield I was just killing the process early, when it was actually running, so it seems like this is normal.

After that I got another issue, which is that when I ran the patch I got a message like this:

Error applying patch to file X. It has probably been updated by other means and can no longer be modified by this patch

The file in question was actually not modified since the release.

Do you have any idea of what could be wrong?

Juan Carlos
0 Kudos