cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
rheinen
Flexera beginner

Silent installation of InstallShield in a Docker container

Dear support,


I have a question about the silent installation of InstallShield Standalone Builder. And particular an installation in a Docker container which is based on 4.8-windowsservercore-ltsc2019.
We are working to containerize all our build vm’s in Docker containers.

I use the command below for silent installation:
/InstallShieldStandaloneBuild.exe /s /v"/qn"

This works for:
InstallShield2016SP2StandaloneBuild.exe
InstallShield2014SP1StandaloneBuild.exe

But is not working for “InstallShield2012SpringSP1StandaloneBuild.exe” (where the InstallShieldPrereqs_dotnet.exe is in the same source installation folder).
This silent installation command does work on a vm with a regular Windows Server 2019 Standard 1809.
So in my opinion it should work on a most recent OS.

I know 2012SpringSP1 is on EOL for a long time but I just want to know if you can help me with a direction to investigate the issue here. Give me possible debug solutions like creating an installation log.
I can’t find the option for this.

The folder “C:\Program Files (x86)\InstallShield\2012SpringSP1 SAB\System” is available after the silent IS 2012 installation within a Docker container. But the command IsCmdBld.exe is not giving any response.

With kind Regards,

Ronald

 

0 Kudos
3 Replies

Re: Silent installation of InstallShield in a Docker container

Hi @rheinen,

Can you please check if the required prerequisites for InstallShield 2012SpringSP1 are installed.
Use the following command inside the container to list all the installed products: wmic product get name 

Also, if its not installed then can you please try to manually install the required prerequisites for 2012SpringSP1, and then try to run IsCmdBld.exe. 

Thanks,

0 Kudos
rheinen
Flexera beginner

Re: Silent installation of InstallShield in a Docker container

In a normal WS2019 vm it worked with and without using the prereqs installer:
InstallShieldPrereqs_dotnet.exe /s /v"/qn"
InstallShield2012SpringSP1StandaloneBuild.exe /s /v"/qn"

wmic product get name :
Name
InstallShield 2012 Spring Prerequisites for .NET
Microsoft Azure CLI
InstallShield 2012 Spring SP1 Standalone Build
Google Update Helper

===============================================

In the Docker container the output of "wmic product get name" is
Name
InstallShield 2012 Spring Prerequisites for .NET

But there is a folder named C:\Program Files (x86)\InstallShield\2012SpringSP1 SAB\system
And there is execute names IsCmdBld.exe
But the executable is not working.

Where can I find the prereq for InstallShield2012SpringSP1StandaloneBuild ?





 

 

0 Kudos
dbost_3734
Flexera beginner

Re: Silent installation of InstallShield in a Docker container

I had similar issue and seemed to have gotten around it by installing InstallShield2012SpringSP1StandaloneBuild on the host OS first. Once installed on the host, I was able to successfully install it into the container.

0 Kudos