cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
raffaeu
Pilgrim

Silent Setup install succesfully but not visible

I have an InstallScript MSI project that deploy also some merge modules. The entire setup is scripted and I just changed the script to allow also a silent setup.
I have 5 features and from the log I can see that are all installed, in fact, each feature creates a log file as a "test" to be sure it has been installed.

If I read the Windows Log it says:
"Windows Installer reconfigured the product. Product Name: xxx 2014.1. Product Version: 8.12.0.0. Product Language: 1033. Manufacturer: xxx. Reconfiguration success or error status: 0."

But if I open the log generated by the MSI I found this at the end:
[CODE]"[ResponseResult]
ResultCode=-3
Action ended 10:33:23: CostFinalize. Return value 1.
MSI (c) (C8:94) [10:33:23:013]: Note: 1: 2205 2: 3: ISAlias
MSI (c) (C8:94) [10:33:23:013]: Note: 1: 2228 2: 3: ISAlias 4: SELECT * FROM ISAlias
InstallShield 10:33:23: Installation aborts, ready to shut down.
InstallShield 10:33:23: Invoking __ResetMsiObject...
=== Verbose logging stopped: 1-4-2014 10:33:23 ==="[/CODE]

And acutally the product is installed because if I run the Setup again it tells me if I want to remove it, but if I open Add/Remove programs I can't find it.
If I run the Setup normal mode everything works fine.

How can I understand why the operation aborted? The log doesn't have any error at all ...
Labels (1)
Tags (2)
0 Kudos
1 Reply
raffaeu
Pilgrim

Re: Silent Setup install succesfully but not visible

So, this is something I found quite annoying because in the log of InstallShield I didn't see anything related to this.
It may return a simple error code like -3, which gives you the reason why the setup crashed.

In my case I was getting a simple Error = -3, which means that my Setup was searching for an .ISS file in order to run silently properly.

Actually it took a while to me to understand this issue, but I found a nice translation table that I want to share here:

-0 Success
-1 General error
-2 Invalid mode
-3 Required data not found in the Setup.iss file
-4 Not enough memory available
-5 File does not exist
-6 Cannot write to the response file
-7 Unable to write to the log file
-8 Invalid path to the InstallShield Silent response file
-9 Not a valid list type (string or number)
-10 Data type is invalid
-11 Unknown error during setup
-12 Dialogs are out of order
-51 Cannot create the specified folder
-52 Cannot access the specified file or folder
-53 Invalid option selected
0 Kudos