Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Setup launcher crashing if Asian language is selected and Windows 10

I have a product that is localized in 10 languages and it produces both 32 and 64 bit builds.

Installshield 2020 R2

It is a basic MSI project that uses the setup launcher.

I'm using the 64 bit setup launcher for the 64 bit build.

When running the setup launcher (x64) and selecting either Japanese, Korean or Chinese, the setup launcher crashes. All other languages work fine.

If I use the 32 bit build, all languages work fine.

Also, if I run the 64 bit installer on a Server 2008 R2 system, it works.

I tried Win10, Server 2016 and 2019. All fail with Asian languages.

I attempted to debug it, but I have no symbols. 

Exception thrown at 0x00007FF77F88BFA0 in GeoDrive.2.2_x64.exe: 0xC0000005: Access violation reading location 0x0000016512914FFC.

I saved a memory dump of the crash:

This link expires in 1 week.

Is this known?? Is there a fix?


Labels (1)
0 Kudos
(12) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi BKast91,

 We tried to replicate the issue, however we are not seeing the crash in our environment, 

I have created a sample project and attached to here, please install the setup and see it install successfully or not.

If observe crash with sample, If you have any anti virus running in your machine, turn it off and then try once,




0 Kudos
Level 3


I know this issue is old now but I am currently experiencing this exact same problem using a 64-bit setup.exe with InstallShield 2021 R2.

I have tried the sample project posted in the Revenera reply above and I can confirm this is sample is exhibiting the same issue.

On further investigation, the issue appears to be related to the way the 64-bit setup.exe is processing the language specific ini files (0x0804.ini).  For the CJK languages the ini file has an additional [Properties] section at the top of the file containing information about the font that should be used to display text in the setup dialogs.  The value for the font name is localised and I believe this is where the issue resides.

If the [Properties] section is removed or the font name is modified to a different typeface such as Tahoma or SimSun (for Simplified Chinese) then the setup.exe runs and displays correctly.

Has this been replicated and confirmed by the development team yet?  If so, when can we expect a fix for it in a future release?

0 Kudos

Hi @AdrianPhillips,

Thanks for your post.

 Could you please share the sample to reproduce this issue, we have tested and confirmed we are not seeing any crashing with Asian language's, 

So it will be helpful for us, if you share a reproduction sample, 

You can also contact support and raise a case. A case will allow us to submit an issue request, if necessary, for tracking purposes. If you have a valid, active, unexpired technical support contract (maintenance plan), could you please open a case with our Support Team, about this issue, by email at

0 Kudos

Hi varul,

Thank you for quick response.

I have attached the sample project that I use that can replicate this issue. The project is largely identical to the one posted before on the thread, except it has been upgraded to InstallShiled 2021 R2. 

I would like to point out that the project has been converted to XML format, software tag identification and digital code signing have been removed so it could be rebuilt on my development machine.

Please note that the testing environment is critical to observe the issue. 

The setup.exe must be run on either an operating system in the specified language or on an English OS with the display language set (e.g. Simplified Chinese) as the default. 

If this is not done, then everything appears to work.


0 Kudos

You mean the machine OS language should be other then english, Please let us know what is your win10 OS language selected.

what language you selected on Installshield setup.exe language selection dialog?

Did you raise a support case, if not created please raise a case with details or steps to reproduction.

0 Kudos

That is correct the machine OS language should not be English.

I am able to reproduce the issue on an English Windows 10 by adding the Simplified Chinese language and setting it as the display language.  You will need to sign out and back in then run the setup.exe

I have attached screenshot of reference

0 Kudos
Level 3

Hi, I am just following up on this issue to see if there has been any further developments as it has been almost 8 weeks now since the last correspondance.

Has it been replicated by support and accepted as a fault?

0 Kudos

Hi @AdrianPhillips 

We are seeing the setup.exe is not at all launching, when we set the machine language to Simplified Chinese language is it the same behavior.

In debuglog log we see an error exit code -1073741819 (Refer screenshot)

Did you see the same behavior or anything we are missing here in reproducing this issue. Please confirm.

0 Kudos

Hi varul,

That is correct, that is same behaviour I am seeing when running the setup.exe.

If you build  an uncompressed image of the sample installer and modify the 0x0804.ini file to remove the [Properties] section or set the FontName to non-localised name as detailed in previous post in this thread.  You should find the setup.exe works and the language selection dialog is shown which could indicate the setup.exe is not handling localised font names correctly.

0 Kudos

Hi @AdrianPhillips 

 Could you please try the attached setup.exe and verify it works for you or not, 

The attached setup.exe is created with IS2022R2 and we are no longer see the crash issue in R2. 

0 Kudos

I can confirm that is working for me. 

It looks like the issue has been resolved in InstallShield 2022 R2.

Thank you for your assistance on this issue.

0 Kudos

@AdrianPhillips : Thanks for your confirmation, you can upgrade to latest IS2022R2 to get latest updates.


0 Kudos