applemac
Pilgrim

SIlent Install gives Resultcode -3. Fetauretransferdata does not install a feature

In an installscript project, I use 3 custom installscript objects included in 3 features. When I debugged the code, during the FeatureTransferData, it does not install one of the feature (Installscript object), but installs the other 2 and also gives Resultcode -3.

Is this is an Installshield bug? Anyone knows the solution?

Thanks.
Labels (1)
0 Kudos
3 Replies
gridman
Pilgrim

Re: SIlent Install gives Resultcode -3. Fetauretransferdata does not install a feature

In an InstallScript project, when you do a silent install, you can use a response file. You first run the installation, entering the input like you were the user, and the response file is recorded. Then when you do the silent install, you reference the response file.

Is that what you are doing?
0 Kudos
applemac
Pilgrim

Re: SIlent Install gives Resultcode -3. Fetauretransferdata does not install a feature

Yes, that is what I'm doing. I recorded all the responses in the response file and run the silent install. But it fails with Resultcode -3.

I've created many iss files and had no issues running them in silent mode so far. Only this project gives me the error. I read in another thread, having more than one Feature in a project can give this error -3.

The particular feature that is not getting installed installs USB Driver that gives a unsigned warning, has it got somehting to do with the Driver?
0 Kudos
applemac
Pilgrim

Re: SIlent Install gives Resultcode -3. Fetauretransferdata does not install a feature

InstallShield Engineers, Anyone knows the solution? Its urgent
0 Kudos