Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Problem with uninstalling an update intall using a new jvm...


Here is the issue I am having:

We have recently changed our installer to use a bundled 1.6 jvm. As a scratch install, everything works fine, both installing and uninstalling the product.

However, since our previous product version used a 1.4 jvm, if we do an update install over it using the 1.6 jvm, it creates problems when trying to uninstall. This is in Windows (I haven't even tried it with our Unix versions yet).

I have discovered how to replace the old version's _jvm with the new 1.6 version during the update install, and am doing that, it works great. The problem is, during the update install, the uninstallWin32.exe does not get updated. So if I try to run the uninstall, it tries to use a 1.4 jvm and can't find it and the uninstall fails.

I have tried so many things at this point with no luck (I even tried to tell the new uninstaller to put itself in a different folder with a different name -- i.e., instead of uninstallWin32.exe in _uninst_IntranetApplications, I used uninstallWin32_16.exe in _uninst_IntranetApplications16. However, it ignored it and never created the items with the new names.

I am getting kind of desperate here. If I try deleting the uninstallWin32.exe from the 1.4 install, running the update install does not create a new one. If I could delete the whole _uninst_IntranetApplications folder first, it would work, but it appears that the update installer grabs a file in there (uninstall.dat) almost immediately and then I can't delete the folder.

I found one post here that said, among other things (removing the _jvm and setting resolveOnReinstall to "true") that I need to "create a new Uninstall Launcher" -- what does that mean, exactly?

Any help to resolve the problem would be very greatly appreciated.

Thank you so much in advance!
Labels (1)
0 Kudos
(3) Replies
Level 9

The problem is that the default behavior is the uninstaller launcher is never changed on updates. Only the uninstaller.jar file. You need to manually delete the uninstaller launcher and add a new one. I have not tried it but what you can do is basically:

Add a new component to your project.
Add a delete file action and delete the old uninstaller launcher wherever it is located.
Most likely: $P(absoluteInstallLocation)/_uninst/uninstaller.bin

Add a launcher action to the component by Insert Action-> Launcher. The new launcher will take on the same behavior for the installer launcher.

You will probably need to create an uninstall launcher for each platform.

Hope this helps!

0 Kudos
Level 2

Thank you Tom for your very helpful reply!

I had to go with another rather complicated solution but I am going to keep this in case something happens and that doesn't work.

Thank you so much for taking the time to answer my question.


0 Kudos
Level 3

What was the complicated solution? I am in the same boat and need a solution as well.

Also, for the uninstaller launcher creation, I am trying to create this for the uninstall executable created for the ISMP 11.5 Universal Installer project.
What properties are need to set in the launcher wizard to get it to work?
0 Kudos