cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Problem downloading Micrsoft .NET 4 Client in redistributables

I have a new installation of IS Spring 2012. I am using Windows 7 x64 and I am logged in as a member of the administrators group. I have created a very simple project in which I have selected MS .NET framework 4.0 client as a setup prereq. Within the redistributables view, when I right-client on this item and attempt to download I get:

The download failed; make sure you are running as Administrator, and that your machine is connected to the Internet. Wouid you like to try again?

I have attempted to do as the message suggests but no luck. I have seen other posts related but those tips did not work either. I have VS 2010 installed but I am using the stand alone version of IS.

thanks for any help,
Jim
Labels (1)
0 Kudos
4 Replies
Highlighted
Pilgrim

Re: Problem downloading Micrsoft .NET 4 Client in redistributables

I ended up call support on this. The problem, at least for me, had to do with the Windows Installer 3.1 prereq item. The piece is a dependency for .NET, so when I tried to download .NET 4 CP in the Redistributables view, it failed because Windows Installer 3.1 failed. This is most likely a Microsoft problem since they moved the download to a new location.

Work around for me was to copy the .NET 4.0 prereq and remove all dependencies using Edit Prerequisite. It worked.

Downloading Windows installer 3.1 still does not work. I guess I will wait for the fix. Win Installer 3.1 is included on XP sp3 and higher so I don't need it since this is my min target platform.
0 Kudos
Highlighted
Pilgrim

Re: Problem downloading Micrsoft .NET 4 Client in redistributables

I'm having the same issue and this is quite problematic. The problem is that the url http://download.microsoft.com/download/1/4/7/147ded26-931c-4daf-9095-ec7baf996f46/WindowsInstaller-K... no longer exists.
0 Kudos
Highlighted
Flexera beginner

Re: Problem downloading Micrsoft .NET 4 Client in redistributables

I had the same problem, after wrestling with support for some time
I solved this by downloading the installshield prerequisites for 2011:

InstallShield Prerequisites
http://saturn.installshield.com/product/is/2011/domestic/othersetups/installshieldprereqs.exe

MS have moved the files, probably they have
decided to stop supporting Windows Installer 3.1.
0 Kudos
Highlighted
Pilgrim

Re: Problem downloading Micrsoft .NET 4 Client in redistributables

It seems that the downloads were just temporarily missing on Microsoft's site. They are working again now, though.
0 Kudos