Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Prerequisite SQL Server 2012 requires reboot sometimes but wont continue after reboot

I have an installer with a prerequisite SQL Server 2012 Express RTM (x86 &x64Wow). The command for that is /ACTION=Install /qs=true /IACCEPTSQLSERVERLICENSETERMS=true /UPDATEENABLED=false /TCPENABLED=1 /BROWSERSVCSTARTUPTYPE=AUTOMATIC /INSTANCENAME=daylight /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="Builtin\Administrators"

So I have to change the behavior to continue the setup because I need to set the instance name of the SQL Server Installation.

So If I run the installer sometimes the setup of the prerequisite needs a reboot and in the log of the SQL Server setup it shows a computer restart is required because of broken fusion ATL. You must restart your computer before you continue.

In the prerequisite i have defined to reboot the machine and resume on reboot but it doesnt reboot and continues the installer. So the SQL Server isnt installed.

If I changed the prerequisite to prompt the user, the prompt for the reboot is shown and if i reboot the installer continues the setup but the setup of the SQL Server did not. So the SQL Server isnt installed again.

So anyone have any idea why I need a reboot sometimes, because sometimes it doesnt need one and everything works fine, I test it on a VM so it is the same enviroment all the time.

A reboot is ok for me but the SQL Server does not continue, so there is maybe something wrong with the installer.

Maybe someone have a solution for this.
Labels (1)
0 Kudos
(1) Reply
Level 2


I am having the same issue here, have you ever found a solution to this problem? I have tried all of the prq options, but nothing works.

0 Kudos