cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

PowerShell Custom Actions not running in New Style Interface Type

Hello,

I added PowerShell Custom Action in my installscript msi project. When i used Traditional Style as InstallScript User Interface Type it works well.  But when i changed it to New Style it not runs during my installation.

 

@PowerShell

Labels (1)
0 Kudos
2 Replies
Highlighted
Flexera
Flexera

Re: PowerShell Custom Actions not running in New Style Interface Type

Hi @Vladimir12 ,

 

What is the issue/error description you are facing with? Can you attach screenshot of that here?

Thanks,

Jenifer

0 Kudos
Highlighted
Flexera beginner

Re: PowerShell Custom Actions not running in New Style Interface Type

This is the way i do.

1.I made project with tradition style Interface Type(pic1)pic1.jpg

2. I addet powershell that installs IIS custom action(pic2)

pic2.jpg

and wana it runns after app search.

3. I install distr on test eviroment. and at the moment with "prepare to install" it runs my script (pic3)

pic3_prepare to install.jpg

. I added log screen (pic4)

pic4_log_running powershell.jpg

 and the whole log (_log_running powershell.log)

4. Then the need arose, to use New Style Interface Type and i changed it in my project and run build (pic5)

pic5.jpg

5. Then i run distr on the same test eviroment rolledback to same state.

6. Now "prepare to install" igoes really quicker and on Installation i have a warning "Installation requires an IIS server to configure the IIS virtual roots. Make sure IIS is installed." (pic6).

pic6.jpg

That means, my script didnt worked, and dist cant figuring IIS. If i end the installation. There is no actions in Log after appsearch, like in previous installation.(nopowershell.log) (pic7)

pic7.jpg

 @powershell

 

Tags (1)
0 Kudos