leigh_johnston
Level 3

Parallel build problem (error -6003: An error occurred streaming...into setup.exe)

Hi,

When are we getting a service pack for ISLE which includes the fix for IOA-000073286?

We would like to build multiple builds in parallel which this bug currently prevents us from doing.

Microsoft's decision not to fix a race condition bug in Visual Studio Installer (when using devenv.com from the command line) instead deprecating it in favour of the third party ISLE and this ISLE bug means we don't have a decent Visual Studio based automated build solution.

Please fix!

/Leigh
0 Kudos
4 Replies
Lenwin
Level 10

Could you let us know the steps that you have performed to replicate this issue in InstallShield Limited Edition.
0 Kudos
leigh_johnston
Level 3

Lenwin wrote:
Could you let us know the steps that you have performed to replicate this issue in InstallShield Limited Edition.


Two builds in parallel initiated by Atlassian Bamboo server using devenv.com of the same solution file specifying different build configurations in order to build different IS projects.

I suggest you merge the fix that you performed in your main product line into LE also.

/Leigh
0 Kudos
Lenwin
Level 10

Could you kindly confirm the version of InstallShield limited edition that you are using.Is it InstallShield 2012 Spring Limited Edition for Visual Studio 2012/2010.
0 Kudos
leigh_johnston
Level 3

Lenwin wrote:
Could you kindly confirm the version of InstallShield limited edition that you are using.Is it InstallShield 2012 Spring Limited Edition for Visual Studio 2012/2010.


Yes that is the version I am using.
0 Kudos