cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

System Search Returns Wrong Value - Installshield 2012 Spring

I have added a new System Search to get the InstallRoot of DotNet Framework from the registry. But its always returning wrong value.

Please find the details below

Added a System Search with the following potions.
1. Folder Path, as specified by a Registry Entry
2. Registry Root : HKEY_LOCAL_MACHINE
3. Registry Key : SOFTWARE\Microsoft\.NETFramework
4. Registry Value : Install Root
5. Store the value to Property : DOTNETROOT

Added another search to use the value of the above property

1. File Path, by Searching Folders
2. File Name : RegAsm.exe
3. Path Found in a previous search : The folder stored in DOTNETROOT
4. Store the value to Property : REGASMPATH

I have called the above 2 properties in a custom action to register dotnet dlls.

Now, I tried to install the setup in a Win 7 system
In the target system, Registry contains the following values

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework : InstallRoot = C:\Windows\Microsoft.NET\Framework64\

But on running the above setup, I'm always getting the value for InstallRoot as C:\Windows\Microsoft.NET\Framework\

Please help in fixing this issue.
Labels (1)
0 Kudos
4 Replies
Highlighted

Re: System Search Returns Wrong Value - Installshield 2012 Spring

This is by design. Your installer is a 32bit installer so Windows Installer is reading from the 32bit registry hive located under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node.
0 Kudos
Highlighted
Pilgrim

Re: System Search Returns Wrong Value - Installshield 2012 Spring

Thanks Christoper for the information.

Is there any way we can get the value based on 32 bit or 64 bit system ??
Do I need to define 2 set of properties? 1 for 32 bit and 1 for 64 bit ?


Regards,
Robin

Christopher Painter wrote:
This is by design. Your installer is a 32bit installer so Windows Installer is reading from the 32bit registry hive located under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node.
0 Kudos
Highlighted
Pilgrim

Re: System Search Returns Wrong Value - Installshield 2012 Spring

Thanks Christoper

I have solved the issue by checking the following option in the system search

Search 64-bit portion of the Registry


Robin
0 Kudos
Highlighted

Re: System Search Returns Wrong Value - Installshield 2012 Spring

You may need two properties. I've had to do this from time to time.
0 Kudos