cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
selwynreynolds
Level 7

Need .NETFramework 3.5 installed FIRST

I need to install the .NETFramework 3.5 BEFORE executing the OnFirstUIBefore. I do not see an option when adding the .NETFramework object to tell InstallShield WHEN to install it. Is there a way to force it to be installed at the very beginning of the setup? :confused:
Labels (1)
0 Kudos
5 Replies
Christopher_Pai
Level 16

You have to wire it up as a Setup Prerequisite so that setup.exe will call the .NET 3.5 framework prior to invoking your MSI.
0 Kudos
selwynreynolds
Level 7

Thanks for your reply Christopher.... but, my project is an InstallScript project. I haven't seen the capability of using Prerequisites for InstallScript projects. Can I do it with an InstallScript project or am I going to have to change my project to an InstallScript/MSI project?

THANK YOU! 🙂
0 Kudos
MichaelU
Level 12 Flexeran
Level 12 Flexeran

OnBegin? I'm not sure I'd recommend it since I don't know why you require it before OnFirstUIBefore though. If you do go that route, be careful not to prevent, say, uninstallation if the framework has been removed (unless uninstallation really requires the framework).
0 Kudos
selwynreynolds
Level 7

I call some functions in OnFirstUIBefore that utilize .NET 3.5 assemblies. That is why I need it before OnFirstUIBefore. I'd rather call those functions before installing all the files so they won't be installed (and thus have to be uninstalled) if the assemblies fail. But, I can certainly change the order of my setup if that is the best way to make sure .NET 3.5 is installed before calling the assemblies. Does that make sense? :confused: Thanks!:)
0 Kudos
selwynreynolds
Level 7

I moved the functions that utilize the .NET 3.5 Framework to OnFirstUIAfter. The installer installed .NET Framework 2.0 (I need both) but did NOT install the 3.5 Framework. Before it did not install either one. Any idea why it would install 2.0 but not 3.5? :confused:
0 Kudos