Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 5

.NET scan at build in merge module - ERROR 1935

Hi All,

I am using minor updates (PATCHES) for my product.
On the last update (Service pack), I added a merge module to one of the products.This merge module includes one .net dll, that by mistake was set to: Scan dependencies and properties, instead of scan properties only.
Now, when building the next SP, Using the msi built for the previous SP as previous package, The patch of the product fails to install with error 1935 and HRESULT 0x80131532. The component that fails to be installed to the GAC is not included in the product or the merge module, but I can see in Orca it is part of the msm - probably because it's a depnendency of the dll I talked about.
I know A.stebner's publishment at My msiassembly table includes entries in File_Manifest column which do not exist in the file table.
But I would like to know what should be the SOLUTION to this issue using WI and installshield best practices.

Thanks a lot in advance for any advice you may give,
Labels (1)
0 Kudos
(2) Replies
Level 5


I tried adding the component to the main installation as scan properties only in addition to the component at the merge module and got error 1310 during installtion (failing to write into file),

Tried making both components - at merge module and main project - scan prop' only, but got error 5108 during build.

The temporary solution was to remove the previous package value, but this is no valid solution as I need to make sure the new patch can be installed correctly on the top of the previous patch.

I need a valid solution that will enable continue using the previous package field,
Would appreciate your help,
0 Kudos
Level 5

Hi all,

As described above, I have an installation which includes one .net component that is installed to the GAC and set as "scan dependencies and properties" in feature A.
In case I install the Release version with feature A not selected (this feature includes this problematic component), And then install a service pack for this product,
Trying to modify the product and add feature A after SP installed causes this error:

Note: 1: 2262 2: Binary 3: -2147287038
Error 1310.Error writing to file

I would appreciate if anyone can share suggestions for resolution of this issue.
0 Kudos