Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

MergeModul is installed twice

Hi everybody,

i have merge modul setup and an basic msi project setup in the web format (which means the result is a single .exe file).

The INSTALLDIR setting in the merge module is set to: [TARGETDIR]

In basic msi the redistributable of the merge module destination is set to: [INSTALLDIR]

The merge modul is installed correctly under the location which the user gives the setup during installation process BUT its installed a second time under hard drive D:\ ?? The install path is C:\Program Files...

Thanks in advance for your help.

Best Regards
Labels (1)
0 Kudos
1 Reply
Level 3

Hi all,

I just wanted to let you know through what the problem was caused and the solution for it. Yes many thanks to myself 😄

The problem is caused through TWO different actions, but the REASON is the same:

1. Reason
The problem caused through deleting a merge modul in any setup.
If you have components (dlls) where the feature .NET Scan At Build Component Settings is set to "Dependencies and Properties"

The setup will check during building if a dependency dll exist in each merge modul. If yes the merge modul is automatically added without any question.

To get around this problem just build the setup locally and check the output. Search lines like this:

"Adding merge module 'My Merge Module Project' that is a dependency of component 'MySuperDll.dll3'"

Go through each component (e.g. 'MySuperDll.dll3') and set the .NET Scan At Build Component Settings is set to "Properties"


Go to the 'Component' table in 'Direct Editor' and set all rows in the column ISAttributes(I4) from the value '17' to '9'

17...Dependencies and Properties

Check also this link:

2. Reason
In general I could reproduce the same by adding a new dll (for example MySuperDll.dll3) to a new setup. This feature was enabled by default and the whole merge modul was included.
To solve this change your default behaviour of Installshield: Go to Tools | Options | .NET and change the default
0 Kudos