Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Launch application on windows 2008

My installer was working fine on Windows 2003 system, and tried the same installer on a Windows 2008 system. The installer has a button, when clicked will launch notepad and open a file. This worked on Windows 2003 system.

The issue is on the windows 2008. When this button is clicked, nothing happens. Is there any specific change that needs to be done, for it to work on Windows 2008?

Please help,

Labels (1)
0 Kudos
(2) Replies
Level 17

This reminds me of a change that we made to a default setting starting in InstallShield 2010. Here's the description from the InstallShield 2010 documentation:

Changes to the Way that a Log File Is Displayed from the SetupCompleteSuccess Dialog in Basic MSI Installations
The ShowMsiLog custom action now launches Notepad.exe from the SystemFolder directory, instead of from the WindowsFolder directory. Thus, if your installation is run on Windows Vista or later and the end user indicates on the SetupCompleteSuccess dialog that they want to view the log file, the installation launches Notepad.exe from the SystemFolder directory. This change was made because on Windows Server 2008 Standard Edition, Notepad.exe is available in the System32 directory, but not the Windows directory.

Note that behavior is available by default in all new Basic MSI projects that are created in InstallShield. If you upgrade an InstallShield 2009 or earlier Basic MSI project to InstallShield 2010, InstallShield does not automatically change the behavior. You can manually change the behavior if necessary: In the Custom Actions and Sequences view, click the ShowMsiLog action. (If this action is not displayed, right-click the Custom Actions node and then click Show All Custom Actions.) Set the Filename & Commandline setting as follows:
[SystemFolder]notepad.exe "[MsiLogFileLocation]"

Thus, the value should contain [SystemFolder] instead of [WindowsFolder].

My guess is that you'll also want to change the path for Notepad so that you're using [SystemFolder], not [WindowsFolder].

I hope that helps.
0 Kudos
Level 3

I realized that on Windows 2008, Notepad.exe was available only in the System32 folder, and thus changing my code to fix it, my problem is resolved.

Thanks for your help.
0 Kudos