numberofcode
Level 3

Japanese Characters in INSTALLDIR

I am running into the following issue (on English Win 7 with English Local):

When installing a product (Basic MSI Project), if I do a "Custom" install, and use Japanese characters (ex: テストパス) in the install path (or select a folder containing Japanese characters in the name), the install will succeed, as long as I don't perform any operations on INSTALLDIR.
Now, if I try and modify INSTALLDIR using MsiSetProperty, the installation will return the following error:
Error 1324. The path ????? contains an invalid character.

Also, if I try to use MsiGetProperty and print the value of INSTALLDIR using MessageBox, it will print questions marks "?????".
If I change the system locale to "Japanese", everything works.
It almost seems like performing an operation in the installscript (MsiGetProperty/MsiSetProperty") might be changing the text from Unicode to ANSI? I've tried using STRING and WSTRING in MsiGetProperty/MsiSetProperty.

Is there anything I can do to make this work in the English local, or will I be required to change the local to have foreign characters in INSTALLDIR?

Thanks.
Labels (1)
0 Kudos
3 Replies
Not applicable

In Releases viewer, select Build tab.

Set Build UTF-8 Database to "Yes", then build it.
0 Kudos
numberofcode
Level 3

It sounds like this option would probably fix the issue. Unfortunately, it appears this option is not available in Installshield 2008 and was added as a new feature in Installshield 2010.


Thanks.
0 Kudos
johnleee
Level 2

I don't there is any other way instead of deleting the older files before upgrade since it will definitely create duplicate files.
0 Kudos