cancel
Showing results for 
Search instead for 
Did you mean: 
lustuyck
Pilgrim

Installshield in Visual Studio unusable again

See thread http://community.installshield.com/archive//index.php?t-197630.html. Today, all of a sudden, the installshield project became unusable again, I cannot expand the project in visual studio 2010! Restarting doesn't help. I have installed the latest version with the hotfix.

Can you tell me how to fix this, because this is blocking me all the time and I have an urgent deploy to do! :confused:

EDIT: reinstalling installshield didn't help either. Please advice!
Labels (1)
0 Kudos
9 Replies
DebbieL
Pilgrim

Re: Installshield in Visual Studio unusable again

Try running this from the Command Prompt window:
"C:\Program Files\InstallShield\2011\System\TSConfig.exe" /registervsip

(Depending on where you installed InstallShield, you may need to modify the path of TSConfig.exe.)

I hope that helps.
0 Kudos
lustuyck
Pilgrim

Re: Installshield in Visual Studio unusable again

I tried it, but it didn't help... now I get Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) when I try to open project properties in my solution! So I applied http://kb.flexerasoftware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=Q... and now the exception is gone; but I still can't expand the installshield project :(

EDIT: the strangest thing is happening: if I copy the entire solution, and open the copy, I can expand the installshield project again. If I then copy it back to the original location, I can still expand it! I don't know why, but copying the entire solutions fixed it (for now).
0 Kudos
DebbieL
Pilgrim

Re: Installshield in Visual Studio unusable again

I'm glad it's working now. I haven't heard any other cases like this, so I'm not sure what was causing that behavior.

If you do encounter this problem again, here are some things that would be helpful to know for troubleshooting:

  • Are you using Visual Studio 2010 with or without SP1?
  • Are you using the English verison of Visual Studio 2010 or a different language? If you are using a different language, which one are you using?
  • Is Hotfix A for InstallShield 2011 applied?
  • What version operating system are you using?
  • What else is in the Visual Studio solution?
  • If you are using Windows Vista or later, did you launch the Command Prompt window with elevated privileges and then call tsconfig? (To launch it with elevated privileges, you can right-click a shortcut for cmd.exe and then click Run as Administrator.)
0 Kudos
lustuyck
Pilgrim

Re: Installshield in Visual Studio unusable again

Thank you for the answer. Here are my replies:

Are you using Visual Studio 2010 with or without SP1? No, SP1 was not installed. But I'm installing it right now, maybe it helps.
Are you using the English verison of Visual Studio 2010 or a different language? English version
Is Hotfix A for InstallShield 2011 applied? Yes
What version operating system are you using? Windows 7
What else is in the Visual Studio solution? Resharper
If you are using Windows Vista or later, did you launch the Command Prompt window with elevated privileges and then call tsconfig? (To launch it with elevated privileges, you can right-click a shortcut for cmd.exe and then click Run as Administrator.) Yes

Actually, something weird is still happening: if I try to rename a file or project, the focus disappears almost immediately, so I can't rename anything in my solution. If I unload the installshield project, there's no problem.
0 Kudos
DebbieL
Pilgrim

Re: Installshield in Visual Studio unusable again

What types of projects are in the Visual Studio solution along with the InstallShield project? For example, are you using Visual C# projects or Visual C++?

Thanks.
0 Kudos
lustuyck
Pilgrim

Re: Installshield in Visual Studio unusable again

DebbieL wrote:
What types of projects are in the Visual Studio solution along with the InstallShield project? For example, are you using Visual C# projects or Visual C++?

Thanks.


Only C# projects, actually its a WPF Prism project. Installing sp1 didn't resolve the rename issue. And it has something to do with the installshield project, because as said, if I unload it, renaming works again...

Another issue that I encountered a while ago, which should be easy to simulate: I have added a sqlite database file to the files in the common app data folder, called let's say parametersue_1.0.sqlite (also added read/write rights to everyone). If I rebuild the installshield project, the resulting setup.exe (single image) works as expected. If I then remove the parametersue_1.0.sqlite and add a new version called parametersue_1.1.sqlite, I can rebuild the installshield project and the setup.exe is created. However, executing this setup gives an error. The reason is that the old database entry is still in the .ise xml file:


LockObject
Table
Domain
User
Permission
Attributes




CFG1CreateFolder[%USERDOMAIN]Everyone18800317430
PARAMETERSUE1CreateFolder[%USERDOMAIN]Everyone18800317430
parametersue_1.0.sqliteFile[%USERDOMAIN]Everyone18800316790
parametersue_1.1.sqliteFile[%USERDOMAIN]Everyone18800316790


So if you remove a file, it seems it is not removed in the .ise file; which causes the setup to fail.
0 Kudos
DebbieL
Pilgrim

Re: Installshield in Visual Studio unusable again

Ah, we haven't seen this before. Just as a sanity check to help determine whether the problem exists with just the WPF Prism project, can you see if you can reproduce the problem with a different Visual Studio project type?

Thank you.
0 Kudos
Highlighted
jsayad
Pilgrim

Re: Installshield in Visual Studio unusable again

lustuyck wrote:
Actually, something weird is still happening: if I try to rename a file or project, the focus disappears almost immediately, so I can't rename anything in my solution. If I unload the installshield project, there's no problem.


I'm seeing this problem too. I'm running VS 2010 with SP1 and the Solution contains only 1 C# project. Problem does go away if I unload the Installshield project. I'm using Installshield 2012 Pro btw.
0 Kudos
TekkGuy
Pilgrim

Re: Installshield in Visual Studio unusable again

I get this problem all the time too. I found a relatively easy way to fix it. If your Setup Project is a part of a solution, right-click the Setup project and select "Unload Project" on the bottom of the context menu. Your project goes gray and in parethisis you will see "unavailable". Now, right-click the same project and this time select "Reload Project" at the top pf the context menu.

Your setup project will reload and it should now be expandable, if it did not already auto-expand on load.

HTH

-Ben
0 Kudos