cancel
Showing results for 
Search instead for 
Did you mean: 
CGCampbell
Pilgrim

Installshield 2018 install silent

Is there anyway to install Installshield 2018 in silent mode? i am not trying to make an installer i am trying to install the software silently.
Labels (1)
0 Kudos
8 Replies
Flexera Jenifer
Flexera

Re: Installshield 2018 install silent

CGCampbell wrote:
Is there anyway to install Installshield 2018 in silent mode? i am not trying to make an installer i am trying to install the software silently.



Hi,

You can use setup.exe /silent to install it silently.Since it is suite setup you can use all the parameters related suite project mentioned here:
https://helpnet.flexerasoftware.com/installshield19helplib/helplibrary/SteSetupexeParam.htm


Thanks,
Jenifer

0 Kudos
CGCampbell
Pilgrim

Re: Installshield 2018 install silent

Jenifer wrote:
Hi,

You can use setup.exe /silent to install it silently.Since it is suite setup you can use all the parameters related suite project mentioned here:
https://helpnet.flexerasoftware.com/installshield19helplib/helplibrary/SteSetupexeParam.htm


Thanks,
Jenifer


Thanks now need to figure out if i can install this on Windows Server Core. With regular windows server 2016 i can install in silent mode just fine but with Server core it appears to hang up and not sure why.
0 Kudos
CGCampbell
Pilgrim

Re: Installshield 2018 install silent

CGCampbell wrote:
Thanks now need to figure out if i can install this on Windows Server Core. With regular windows server 2016 i can install in silent mode just fine but with Server core it appears to hang up and not sure why.


Well was able to install installshield 2018 SAB on a docker container but it fails to build any installers with. Dont think its possible to put installshield inside a docker container sigh

InstallShield (R)
Release Builder
Copyright (c) 2018 Flexera.

All Rights Reserved.

Build started at Feb 13 2019 12:12 AM
Building Release: Release

Created release folders
InstallShield Script Compiler
Version 24.0.0.464
Copyright (c) 2018 Flexera. All Rights Reserved.

Compiling...
Setup.Rul
Linking...
Setup.inx - 0 error(s), 0 warning(s)
Checking string table references...
Calculating size of cabinet files...
ISDEV : error -7041: Could not create instance of CABEngine. "CABEngine component might not be installed or registered
properly. You may need to reinstall InstallShield."
Release - 1 error(s), 0 warning(s)
Log file has been created:


Build finished at Feb 13 2019 12:12 AM
0 Kudos
Flexera Jenifer
Flexera

Re: Installshield 2018 install silent

CGCampbell wrote:
Well was able to install installshield 2018 SAB on a docker container but it fails to build any installers with. Dont think its possible to put installshield inside a docker container sigh

InstallShield (R)
Release Builder
Copyright (c) 2018 Flexera.

All Rights Reserved.

Build started at Feb 13 2019 12:12 AM
Building Release: Release

Created release folders
InstallShield Script Compiler
Version 24.0.0.464
Copyright (c) 2018 Flexera. All Rights Reserved.

Compiling...
Setup.Rul
Linking...
Setup.inx - 0 error(s), 0 warning(s)
Checking string table references...
Calculating size of cabinet files...
ISDEV : error -7041: Could not create instance of CABEngine. "CABEngine component might not be installed or registered
properly. You may need to reinstall InstallShield."
Release - 1 error(s), 0 warning(s)
Log file has been created:


Build finished at Feb 13 2019 12:12 AM


Hi,

Possible cause would be failure instantiation of MediaBuild40.dll,

-can you try registering C:\InstallShield\2019\System\MediaBuild40.dll on the docker instance?
-Give it a try for basic MSI project building also,to get to know root-cause.

Thanks,
Jenifer
0 Kudos
CGCampbell
Pilgrim

Re: Installshield 2018 install silent

Jenifer wrote:
Hi,

Possible cause would be failure instantiation of MediaBuild40.dll,

-can you try registering C:\InstallShield\2019\System\MediaBuild40.dll on the docker instance?
-Give it a try for basic MSI project building also,to get to know root-cause.

Thanks,
Jenifer


So i register the dll, and built a basic msi and it appears to work but unable to build a installscript project.
0 Kudos
CGCampbell
Pilgrim

Re: Installshield 2018 install silent

CGCampbell wrote:
So i register the dll, and built a basic msi and it appears to work but unable to build a installscript project.


After more testing, i can build msi install script project just not a pure installscript project. i did try CD-ROM option for compressing files which does not compress but it still fails with the same error.
0 Kudos
Flexera Jenifer
Flexera

Re: Installshield 2018 install silent

CGCampbell wrote:
After more testing, i can build msi install script project just not a pure installscript project. i did try CD-ROM option for compressing files which does not compress but it still fails with the same error.


Hi,

Can you give me docket container details like which platform & other details?


Thanks,
Jenifer
0 Kudos
CGCampbell
Pilgrim

Re: Installshield 2018 install silent

Jenifer wrote:
Hi,

Can you give me docket container details like which platform & other details?


Thanks,
Jenifer


This is my docker file

FROM microsoft/dotnet-framework:4.7.1
ADD install c:/install
RUN powershell -Command C:\install\InstallShield2018SP1StandaloneBuild.exe /S /debuglog /v/qn; get-process; Start-Sleep 360; get-process
RUN powershell -Command Copy-Item "C:\install\server.ini" -Destination 'C:\Program Files (x86)\installShield\2018 SAB\System'
RUN powershell -Command Copy-Item "C:\install\InstallShieldSkins\*" -Destination 'C:\Program Files (x86)\installShield\2018 SAB\Skins' -Recurse -Force
run powershell -Command Remove-Item -path c:\install -recurse


I have also tried using FROM mcr.microsoft.com/windows/servercore as well with same results. The Install folder has the installer, ini files, skins that i copy and replace etc during the process. I also found out to get this to install in docker the host machine needs to have the same installer installed on the machine and the OS needs to match. I am currently using Windows Server 2016 and the images i am using from microsoft should be 2016 as well.
0 Kudos