cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chilin
Level 2

Installation fails on Windows XP

When I ran setup.exe on Windows XP system, an error message displayed:

"This installation package cannot be installed by the Windows Installer service. You must install a Windows service pack that contains a newer version of the Windows Installer service."

The system is Windows XP SP3 and the Windows Installer is V4.5.

Any idea how to fix it?

Thanks.
Labels (1)
0 Kudos
2 Replies
TsungH
Level 12

Looks like the package you tried to installed might have required Windows Installer 5.0. Please refer to Run-time requirements of Windows Installer.
0 Kudos
chilin
Level 2

That's what I think. However, Windows Installer 5.0 seems to be not supported in Windows XP. The same setup.exe can run on the Windows 7 system which has Windows Installer 5.0.

I wonder if anybody can run the setup.exe (which is built on InstallShield 2013 Express) on XP system?
0 Kudos