cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
agshah
Level 6

InstallShield - Specifying icon for setup.exe

Hi all,
I have InstallShield 2018, tried 3 project types, Basic MSI, InstallScript and InstallScript MSI.

I looked at InstallShield help titled "Specifying the Icon for the Setup Launcher" and specified an .ico file for setup.exe for all three project files:
*****************************************
In the View List under Media, click Releases.
In the Releases explorer, select the release that you want to configure.
Click the Setup.exe tab.
In the Setup.exe Icon File setting, specify the fully qualified name of the file that contains the icon that InstallShield should use when it creates the Setup.exe file at build time.
*****************************************

Now I see the icon displayed on the setup.exe. Next, I run setup.exe and see the icon in the task bar. But after a brief moment the icon switches back to the default InstallShield icon in the task bar.

Any idea how to keep the custom icon in the taskbar throughout the installation?
Labels (1)
0 Kudos
5 Replies
rguggisberg
Level 13

The icon might be cached. Try it on a fresh PC that has not had the setup icon.
Or try temporarily changing the icon name, rebuild the IS project and see if it works then.
0 Kudos
Jenifer
Flexera Alumni

Hi agshah,

Setup icon behavior will vary a bit between Basic MSI & InstallScript(Installscript MSI) projects.In basic MSI project,setup.exe will invoke msi file hence you could see msi icon after few seconds of launch.
But in installscript & installscript MSI projects,setup.exe's icon file will change as per Releases->Setup.exe->Setup.exe icon file setting.If it isn't working as expected you can contact Installshield support.

I think caching couldn't be the cause.


Thanks,
Jenifer
0 Kudos
agshah
Level 6

thank you both for your responses.

1. I tried on 4 different machines so caching may not be the issue.
2. Basic MSI project in IS2018 also allows you to build a setup.exe which is what I tried and assigned the icon as outlined in the doc.
But it disappears from the task bar after showing up initially. Strange.
0 Kudos
Dan_Galender
Level 10

Have you tried viewing the folder containing the setup.exe with different size icons (right-click, View->Small icons, Medium icons, Large icons, and Extra large icons)?

I seem to remember having your issue when the icon wasn't available in the size I was viewing, but showed up correctly when viewing the contents of the folder with different icon sizes.
0 Kudos

Hi, did you fix this issue? I am experiencing same issue with InstallScript MSI.
0 Kudos