Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

InstallShield LE reports license is corrupted constantly, and repair crashes vm

The setup: I have a MacBook Pro on which I run Windows 8.1 via Bootcamp, and I typically use this machine as a VM while booted into the Mac OS via VMWare Fusion. I am using Visual Studio 2013 Professional, and trying to use InstallShield Limited Edition with Visual Studio.

The problem: When I load a solution with an InstallShield project in it in Visual Studio, every single time I load it up, a dialog pops up saying, "The product license has been corrupted. You must repair the license before you can continue. Click yes to repair now."

If I click "Yes", then the repair dialog pops up, but almost immediately I get a popup from VMWare fusion saying, "You do not have write access to a partition. Select Allow to override access rights for this write. Select Allow All to override access rights for this and subsequent writes to all raw disk partitions during this run of the virtual machine" (there are also options for deny/deny all). No matter what I click, I next come to another VMWare Fusion error dialog saying, "The operation on the file "/dev/rdisk0" failed (Bad file descriptor). The file system where disk "/dev/rdisk0" resides is full." Here you can click Retry or Cancel. Retry will just bring the same dialog over and over again. Cancel leads to one final error message:

"VMWare Fusion cannot synchronize with the disk before canceling. Disk /dev/rdisk0 may be inconsistent" --- And with that, the virtual windows machine completely crashes.

Screenshots of all 3 error messages are attached to this message. There was absolutely nothing written to InstallShield.log located at C:\Program Files (x86)\InstallShield\2013LE\System, so unless there is another log of which I am unaware, there is nothing to see there.

Note: If I boot natively into Windows, rather than running it as a vm, things work fine.

I haven't been able to find anything on the forums about this... Does anyone know what might be going on, or what InstallShield does under the covers when it tries to "repair" a corrupted license? Anyone know why the license gets routinely corrupted when running Windows as a vm in VMWare Fusion?

Thanks in advance for any assistance!
0 Kudos
(2) Replies
Level 6 Flexeran
Level 6 Flexeran

I don't believe that InstallShield licenses are designed to handle being installed and activated on a local machine that is then converted/run as a VM. This can cause license corruption issues and may explain the behavior you are seeing.

I expect you would have more luck if you were to run the Windows OS as a VM before installing InstallShield, then install and activate InstallShield on the VM.
0 Kudos
Level 2

Thanks very much for replying, jlynch11. Much appreciated!

The one configuration I have not yet tried is installing ISLE on a similar Windows 8.1 machine with VS 2013, but one that runs *only* as a VM (not existing physically on a bootcamp partition). I suspect that one will work, but I'm going to make sure to back up that machine fully before trying such a thing after seeing the damage that seemed to be caused by ISLE's attempted license repair on my bootcamp partition running within VMWare Fusion.

What I would be very interested to understand is what ISLE is doing under the hood with licensing. It seems exceptionally odd that a licensing scheme would require such deep impact on the operating system that would result in such incredible corruption of the machine's ability to boot. I wish I had some better visibility into what is going on, so I could see if there is some way to work around the issue. If someone has any knowledge of what's happening, I would love to learn.

For now, I suspect I am ok as long as I load the ISLE project *only* when booted into Windows natively, and making sure to *always* click "no" when ISLE asks me to repair a corrupted license when accessing my bootcamp windows machine via VMWare Fusion, within the Mac OS. I'm just afraid to test it out until I absolutely must, since it left me with a completely non-bootable machine just last week, and a machine that would only boot as a VM, not natively, until just a day ago when I was able to successfully get a bootable USB to run a repair boot operation.
0 Kudos