cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
wilsonchan18
Level 3

InstallShield LE cannot Detect Office 2007

Hi,

I am using VS 2012 with the built in InstallShield Spring LE (Limited Edition). I have finished writing the C# code for basically opening and changing data of excel like a model, targeting any CPU, XP OS and up, and Office 2003 and up.

The problem is that after I built the EXE with VS 2012 and after I've put it into the Installsheld LE, using ".NET 4.5 (if not detected, install from the local setup file) & office 2003" perquisite for vista OS and up, also using ".NET 4.0 Client (if not detected, install from the local setup file) & office 2003" perquisite for XP OS, Cause XP OS cannot install .NET 4.5 from what I know.

I realized I have a problem when opening the single image setup in a 64 bit win 7 OS with office 2007. The installer says that it cannot detect office 2003 or even later version. I am quite struggling with this.

Is is that I supposed to add the windows installer as well as VSTO 2010 Runtime, as a prerequisite for the setup. Or did I do something wrong. Or.... The InstallShield not supporting 64 bit installation as lot of others saying, yet, I really firmed that I have chosen any bit of CPU.....

Thank you Guys, really hope you could help me out, cause I am really a green programmer still.

Good Day,

Wilson
0 Kudos
1 Reply
chiranjeevi
Level 7 Flexeran
Level 7 Flexeran

Duplicate thread, Please refer to below thread for further updates.

http://community.flexerasoftware.com/showthread.php?205750-InstallShield-LE-cannot-Detect-Office-2007&p=486524#post486524


Thanks
Chiranjeevi
0 Kudos