Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Install won't update files in minor upgrade

I have a basic MSI install. I added 4 new dlls to my install for SQL Server 2012 integration. But when my users try to install my new version (3.1.47) on top of the old version (3.1.46), their files are not being updated.

The product guid and upgrade guid are the same between these versions. The package guid is different.

If the user uninstalls and reinstalls then all the files are updated perfectly.

What can I do to fix this? I tried setting a lot of the files to "Always Override" and that still doesn't seem to work.

And I know that the install is kinda working because if they try to install again, it takes them right into maintenance mode. If they do a repair, all the files get updated also.

I tried to bulid a new install (3.1.48) and install it on top of 3.1.47 and it works perfectly. But I would assume it would because the files are the same between .47 and .48. But I don't think it will work going from .46 to .48 either.

Any ideas? Should I just change the product code and force a major upgrade and call it a day?
Labels (1)
0 Kudos
(2) Replies
Level 6

I'm using an InstallScript MSI, and have the same issue. When looking at the verbose log file, I found an error message that stated that removing a component from a feature is not allowed and this caused the installation to fail to update the files. This was strange as I didn't delete any components from the installation, I added one. The first time it happend, I was able to add then new file to an existing component. After that only solution that seemed to work was to move to a major upgrade.

Robert M.
0 Kudos
Level 7

I called Flexera support and they helped me realize that I had a component that was not associated with a feature. I had to associate it again and then I used the conditions (setting the condition to 0 or false) to prevent the file from installing.
0 Kudos