cancel
Showing results for 
Search instead for 
Did you mean: 
yafitmayo
Flexera beginner

Install Visual C++ 2015 redistributable when redist update 3 already exists

I have a computer with Visual C++ 2015 redistributable update 3 installed.
Now, I'm trying to run a setup file that has Visual C++ 2015 redistributable (with no update) x86 and x64.

Setup fails.
I'm getting the follwing error message:
"The installation of Microsoft Visual C++ 2015 redistributable package (x86) appears to have failed...."
I'm also getting an error for x64.

It looks that I need to edit prq for both x64 anx x86 package.
Any ideas how to handle this?
Labels (1)
0 Kudos
2 Replies
MattQVI
Flexera beginner

Update the prerequisite condition?

It sounds like you might need to update the prerequisite condition. The canned InstallShield Visual C++ 2015 x86 condition looks for a registry key that does not exist. You have update 3 already installed but it probably has a different registry key so it tries to install. But since the Visual C++ runtime that is already on the system is newer - you might run into problems. What are your thoughts on making the Visual C++ 2015 prerequisite update 3 in your install? Keep in mind that it you switch to it, you need to uncheck the old one.
0 Kudos
Highlighted
vbp0001
Pilgrim

Visual C++ 2015 redistributable update 3

tuti2017 wrote:
I have a computer with Visual C++ 2015 redistributable update 3 installed.
Now, I'm trying to run a setup file that has Visual C++ 2015 redistributable (with no update) x86 and x64.

Setup fails.
I'm getting the follwing error message:
"The installation of Microsoft Visual C++ 2015 redistributable package (x86) appears to have failed...."
I'm also getting an error for x64.

It looks that I need to edit prq for both x64 anx x86 package.
Any ideas how to handle this?



I am in the same situation as you. What did you end up doing?
0 Kudos