Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Install Shield 2015 Redistributable list doesn't list redistributable

I have a prerequisite file in the C:\Program Files (x86)\InstallShield\2015\SetupPrerequisites directory.

If I open up one .ism file the prerequisite shows up in the redistributable list, but if I open up another .ism file it does not.

NOTE: It used to show up in the .ism file that it no longer shows up in.  I wanted to run a test.  I thought I just unchecked the prerequisite, but I might have "deleted" it within the InstallShield 2015 gui.  (The file still exists in the SetupPrerequisite directory, and as noted, it shows up in a different .ism file).


Labels (1)
0 Kudos
(4) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @AndyTK ,

What is your project type? Is the prerequisites you are seeing is custom prq or installshield's default shipped prq files.

Could you please share a screenshot to demonstrate the issue, because prq listed in SetupPrerequisites folder will be available for all ism file.

0 Kudos



The prq files are in the correct directory, but they don't show up as options in the Install Sheild development environment.

NOTE: I had to create these project files because Revenera doesn't have official .prq files for SQL Server 2022 Express.  The URLs point to the 2019 executable, but that shouldn't matter as I have the executable local.  But my problem is that it isn't showing up at all, not that it is trying to download the wrong version.


Thank you for looking into this,


0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @AndyTK ,

 You are not seeing this prq for any project or only to this project ism file?

You can create a test installscript MSI project and verify you are able to see the new server2022 prq or not.

If you face the same issue with new project as well, try the suggestion of unblocking the prq in right click properties,

Even after changing if you still face an issue, check the Prq file location under Tools --> options--> PreRequisites tab  

and verify the path is same path where you copied the server2022 prq.

Even path is correct and the prq file is unblocked, still you face an issue, then try to create a prq and then try to see the newly added prq shows in the list or not.

0 Kudos
Level 8

Just tried with your attached prereq's and it worked in my InstallShield 2015.


May be the files are "blocked" because you received from the internet ?




0 Kudos